MIDI Transpose Issue

Anybody else having this problem with MIDI Transpose?

  1. Select a MIDI event, say an 8 bar section.
  2. Go to the MIDI Transpose tool and set it at -12, for a 1 octave drop.
    Result: One or two notes move and they haven’t dropped an octave! :open_mouth:

Current work-around:

  1. Go INTO the MIDI event via the Key Editor and select all of the notes you want transposed down an octave.
  2. Use the MIDI Transpose tool to execute the 1 octave drop. All the notes will now drop an octave.

Why can’t I select the entire event from the project window and drop/raise the part in mass? That’s how it worked right up to N6.5. Did they change this or is this some kind of bug?

Not seeing that problem here. But maybe I don’t understand. (e.g., there is no tool called the “midi transpose tool”)

Try this in a new, empty project to investigate:

  1. Create one midi track
  2. Create one midi part
  3. Open the part in the Key Editor, add a bunch of notes
  4. Close Key Editor
  5. With the Select tool, click on the midi part to select it.
  6. Open Transpose Setup… from the MIDI menu
  7. Set Semitones to -12, and make sure nothing else is activated in that dialog.
  8. Hit OK

What happens?

Exactly what I described in my 1st example. Only a couple notes move and those that moved did not drop an octave.

What you call Transpose Setup is what I was calling the Transpose Tool. Not sure what the difference is.

Strange… Have you ruled out corrupt prefs?

I haven’t ruled out anything. I’m confirming that I SHOULD still be able to select the event and transpose in mass.
Now, I’ll start looking for the problem. How do I correct corrupt preferences?

Could you please have a look at this knowledgebase article?

https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Thanks! I tried it and it stopped being a problem with prefs disabled. When I closed it out and went back to normal mode, it started working as expected. :astonished: I didn’t actually DO ANYTHING ( I didn’t delete my prefs). Just the checking seemed to be equal to banging on the side of the TV set! :laughing: In any case, now I’ll know where to look, if it happens again.

You have Fonzie jukebox powers!