Midi velocity not working


The velocity I set in the key editor is not being “read” by cubase. The velocity is fixed whatever the value is. Is there an option in midi like in the faders to “read” the automation?


Are you certain that the Instrument (or at least, its current patch) to which that track is routed actually responds to velocity anyways? (i.e. does that same patch respond to velocity when you play it live from your keyboard?)

You’re right, it’s not responding live either. I’m using a violin ensemble with Kontakt 5. Where can I change that?

So it isn’t a Cubase problem :wink:
You’d have to edit the Instrument in Kontakt itself. (Just to verify that, try loading a typical piano sound into Kontakt, which, presumably will respond to velocity :wink: )
Which violin ensemble (i.e. from which library) are you using? (is it from N.I. or some third-party developer?)

It’s a violon ensemble from N.I.

I can’t find where I can adjust this particular library. Velocity works well using other instruments.

Could this be it?

I’ve tried the different velocity curves. It just changes the crescendo but does not change the volume of the note.

Hmmm. Have you tried creating a new track (not duplicating) and routing it to that instrument?

If you zip and upload your cpr, someone will have a look at it.

Is the Vel->Vol control set all the way down (CCW)? Are the Min Max values set to the same number?

SteveInChicago: I created a new track and it seems to be working now.


Well, that was the sledge hammer solution. :laughing: Glad it worked!

Hi everyone, I think I have a similar problem here. Yesterday I upgrade my Cubase LE7 to LE9.5 because have some problem with a VST instrument: Sytrus (Image Line).
The problem was that Cubase stopped running every time tried to open a project with Sytrus inside. ALL my projects are realized with Sytrus, so I worried a lot :cry: . I upgraded Sytrus to the latest version (2.6.91) and upgraded Cubase. Now everything works again, but Sytrus doesn’t read the velocity of Cubase, also live from my midi keyboard (even in standalone outside cubase). If I put the note midi at 1 or 127 the volume does not change. Another VST (Bazille) have the same problem. While others go without problems. The Image Line send me e .dll file to fix the problem inside Sytrus but still not working.
How can I understand if it’s a problem of sytrus or cubase? Someone can help me please?

Thank you a lot!