MIDI won't trigger without Monitor Enabled (HELP!!)

My question is regarding MIDI and Audio Output basically.

I just recently started noticing that when I setup a MIDI channel and assign it to a VST instrument that no sound is heard when I trigger the channel via a MIDI controller.

I can see the MIDI activity indicator in the transport light up so I know the MIDI is being transmitted, but no sound comes out. The only way I can actually hear the sound has been enabling the monitor on the MIDI track which doesn’t seem right.

If I use the virtual keyboard within the VST (for example, HALION), then I get sound with or without the monitor enabled on the MIDI track.

I’ve had some issues requiring me to totally remove Cubase and re-install ground up so I don’t know if there is still something wrong within the program or if there is some setting that got changed during the reinstallation causing the problem.

But I don’t recall previously having to enable the Monitor on the track to receive sound from VST instruments via MIDI. Or maybe it should have been working this way all alone and the installation fixed what I perceived previously as being the normal way the program should operate???

I am currently working on a time critical project and I need this fixed ASAP. Anybody? Please!!! :angry:


You have to enable Monitor or Record Enable button. This is totally correct.

If you play the VSTi virtual keyboard, it’s rooted directly in the VSTi, there is no incoming MIDI signal from any external source.

Thanks Martin

So the previous installation must have actually been flawed because it wasn’t working that way before. I don’t suppose there is a way to enable the monitor by MIDI track selection only so I don’t have to always manually enable the monitor with the selection of a new track is there?

In the VST preferences section I see Auto Monitoring options as:

While Record Enabled
While Record Running
Tape Machine Style

Which none of those would be ideal since I’d want to only here the instrument on the track selection, would not necessarily be in record mode.

Sorry if these questions sound stupid but I’d been plagued by so many issues until wipe/out and reinstall seemed the only option; and now I’m seeing things work as they should for possibly the first time. :frowning:

You can record-enable tracks on selection, which also activates monitoring even though the monitor button isn’t lit.

•To record-enable audio or MIDI tracks on selection, activate the Enable Record on Selected Audio Track or the Enable Record on Selected MIDI Track option (File > Preferences > Editing > Project & MixConsole).

By default, this is enabled in Cubase. So you can skewer the MIDI / Instrument Track and start to play the Instrument immediately.