Missing bar number in Write mode, galley view

I have a large complex orchestral score, and I don’t know what I did, but I did something funky here. In the screenshot, you can see at the top that m368 and m369 are fine, but then in m370, it switches to 3/2 but there is no bar number. Then the next bar has a bar number but it’s m370 (and clearly should be m371).

All the music beyond this point is in the right location. The ONLY thing that’s weird is the numbering of the bars. I have no idea how I got it into this state, but how might I fix it?

It looks like you defined the 3/2 with a pickup of 2 beats. Pickup bars have no bar number (or 0) by default.

Thank you. No idea how I did that. How do I fix it? I tried shift-M in both m370 and m371 to set them both to 3/2, and it didn’t reset this. I tried removing that signpost in the fourth visible measure of the screenshot, and that didn’t do anything. What else can I try?

In order not to mess up your score, it’s better to first make sure the rest of the music keeps the correct time signature, before deleting one in the middle.
Therefore: first insert a new time signature of 3/2 (without pickup) in bar 370 (current number), then delete the 3/2 time signature in the previous bar. The (as yet) unnumbered bar in between will adapt to the ¢ from before, and the bar numbers will correct themselves automatically.
BTW: I tried it in a small test project, and when I enter a 3/2,2 in the middle, the signpost is on the pickup. I’m not sure how you managed to get it on bar 370. Is there a hidden TS underneath?
If this doesn’t help, seeing a cut-down version of the original project (just these few bars) might be interesting to investigate. Can you post it?

Post a sample of your Dorico file so that we can see what can be done.

Thank you all for the offer to take a look at it. I made a duplicate of the file and deleted most of the content prior to m368, and also deleted most instruments to get the file size down. Here it is attached. I’d be most grateful if someone could let me know how to fix it. (In other words, yes I want it to change to 3/2 in m370, which should be the third visible measure above, and the next measure should be m371, and so on.)

z test file 2.dorico.zip (1.2 MB)

Go into Write mode.
Unhide the 3/2 time signature in bar 370 (select the time signature signpost, open Properties and uncheck Hide time signature).
Select the first rest in the incomplete bar between 369 and bar 370.
Press shift-B, and type -1 then press Enter.
If you now have too many or too few bars, use shift-B and then either
-1 Enter to delete a bar
1 Enter to add a bar.

1 Like

@StevenJones01 can’t thank you enough for this. Using your steps I got it straightened out. What a weird one. I have no idea how I got this measure into this state, but it’s all fixed now, and I painstakingly cross-checked all instruments in the score to make sure things are right again. Thank you!

1 Like