Missing Loops & Samples

@Romantique_Tp thank you so much! Worked perfectly for me too!

Everything that is described here in this topic did not help me solve the problem with missing loops and samples. Need help

Completely with you. This only serves to rescan the content, but does not resolve any missing thumbnail images or content in the sidebar. How is this still an issue in 2023? I have tried every fix I can find on here to no avail. I have removed/reinstalled the content and even Cubase 12.

(Mac OS, Intel, Monterey)

Any more insight anybody?

1 Like

Hey ! After 6 months. I’m the bearer of good news. I feel like the GA messiah, I have finally resolved the problem and this involved absolutely none of the various solution proposed anywhere and absolutely without steinberg customer service being of any help.

Long story short :

It start like some other solutions. (I’m on iMac M1, but I guess this transposes to windows too?)
1- Close anything Cubase related
2- Go to library (cmd-shift-L) / Preferences.
3-In there remove both Cubase and Groove Agent folder. Not just some files, THE WHOLE folders and empty the bin.
4- Launch Cubase. The software will now rebuild everything properly BUT don’t go and open an old song yet.
5-Start a new project and try to add a groove agent track. This should work. Save the project and close it.
6- Now you can open an old song and the GA in it will be bugged. Don’t play anything. Now you’re going to ‘repair’ your track.
7 (optional)- If you made a custom drum kit and want to keep the settings then save your kit’s settings so you can recall them in another instance.
8- Create a new GA track and load the kit you’ve just save from the other track.
9- Drag your midi part to the new track.
10-Remove the old track.

You’ll see that everything works fine.
Reinstalling libraries or even Cubase won’t change anything. I’ve tried. Just do these 10 steps and you’ll be good to go.

Longer story :

I had tried everything and I gave up. But earlier this week my wife ask me if she could use my iMac and I made a session for her. I thought “What if I tried launching cubase on her session?” and everything worked perfectly. I started to think it had something to do with the files and folder that are created at first launch so I decided to find what these files were. And I didn’t find anything.

So I started enquiring “cubase factory reset” as this basically the same as launching from a new session. Going through various threads I found someone talking about removing the whole cubase folder and how it would reset the software. I felt this was it and gave it a try and boom it worked. Interestingly re-installing doesn’t work even if this could be considered as a factory reset too. I have no answer for that, maybe some files are staying when reinstalling I have no idea.

Anyway it works and I’m happy.
I hope this helps !

because there is no folder once i open Preferences, there is no folder titled Cubase 12_64…due to this i cannot find the three files you’ve outlined…xml //.db//.bin.
typing the file full name plus extension and searching (using a mac) within finder does nothing to locate the files.
one day (late last week they were all there (loops and samples) then disappeared and now i can’ t do anything to have them restored.,
are there any reasons why i’m unable to find the folder Cubase12_64.
be grateful for any pointers on this.

Hi Romantique_Tp. I have a similar problem in Cubase 12. The images of the loops appear like album covers. However, when I click, there are no files there.

I tried deleting the suggested Mediabay files in appdata, however, the problem remained the same.
Any clues? With thanks

Did you quit Cubase before deleting the files?

Thanks. I think I did. I’ll try again.

The album covers if the media files show up but when I click on them, no files.

Thanks again

Do you mean this by “album covers”?

Yes. That’s all I see Johnny.

Yes. Thats what appears. When I click, nothing

Do you see any files in the Sound Browser?
menu Media → Sound Browser,
then on the left side select “VST Sound” and e.g. “Analog Techno”. Any files displayed there?
Consider resetting any filter

and make sure all media types are shown…

Hi Johnny. I quit, deleted and it worked. Thanks so much for helping.


1 Like

That was the problem. Fixed. Cheers again

Thanks a million Romantique_Tp!

This solved the problem for me also.

Worked a treat - thanks, been bugging me for a while :+1: :+1:

Hi All, same happened to me but when I clicked into loops and samples and then selected any of the groups, there was no list of sounds. I eventually found that a little button at the top of the right zone in the program called ‘Reset attribute filter’ had been selected and so I deselected it and everything appeared now. Hope this helps someone.