Missing MIDI output after Instrument track disabled/enabled

I am having an issue where MIDI tracks have a missing output when the corresponding instrument track they are being sent to is disabled and enabled.

  1. Create an empty project
  2. Add an instrument track and load a VSTi ( I have tested this with both EW Play 64-bit and Kontakt 5 64-bit )
  3. Load patches into the VSTi (say 4 EW Play string articulations)
  4. Create 4 MIDI tracks
  5. Set the channel of each MIDI track to correspond with the 4 patches loaded (i.e. 1, 2, 3, 4)
  6. Add a second instrument track and load a second instance of EW Play
  7. Disable the first instance of Play.
  8. Enable the first instance of Play.
    ==> In the mix window the MIDI tracks will say ‘Missing:01 Play’

Just to note that if there is only a single instance of Play or Kontakt and you disable/enable that instrument track, the MIDI tracks ‘find’ their routing to the VSTi patches with no problem. The problem occurs when there is more than one instance of the same VSTi then the MIDI routing is ‘lost’.

Cubase Pro 9.5.41 - Build 287 - Oct24 2018

Windows 10, 64-bit
Intel i7 5930K
32GB RAM
NVIDIA GTX 1080
Kontakt 5 v5.8.1
EW Play v6.0.2

Kind regards,
Dale

Hi,

If the 2nd Instrument is not involved, then it works as expected. But I can confirm your description.

Reported to Steinberg CAN-21034.

Hello
I have the same exact same Issue here and I’m in cubase pro 10.0.20 Build 187
Impossible for every midi track associated with an Instrument track to recover their output after disabling/enabling the related instrument track.
I was so happy to built a bigmockup and then saving memory by disabling every temporary not needed instruments Butwith taht issue… I’m so disapointed… :cry: :cry:

Running A Mac OS Sierra MacPro 10.12.6
2 x 2,93 GHz 6-Core Intel Xeon

Thanks for having reported it in Cubase 9.5, Should I also report it for the v10 ?

Best
Nicolas

Hi,

Yes, this has not been fixed.

The issue is present only if you use multiple instances of one VSTi in the project. So for example if you use HALion 6 two-times in the project. If only one instance of the VSTi is present, then it works as expected.

This is a great problem. I think it happens because it changes the ID of the VSTi so when you enable the instrument again, as it doesn’t have the same ID than before, the MIDI track is unable to find it.

Which is something that should have been fixed by now, as this problems happens since I have CUBASE (version 9) at least.

However, here we are with the same problem and may it be present for many many years from now :frowning:

Same issue still with 10.5… This makes disable/enable track functionality useless if you have to manually redo all the midi outputs.

Hi,

Yes, it has not been fixed for Cubase 10.5 (hopefully yet).

Has this bug been reported officially?

Yes

Hi guys. Any new yet? 'cause I ran into this issue right now and we’re 2020. Cubase 9.5 Thx

Ow, problably not. Last post is Jan 07 2020 :slight_smile:

And here I just reposted this…my bad not to look first. I’m moving to a template all within Cubase and suppose I shall be reassigning a lot of tracks this year…Steinberg please please fix! :slight_smile:

https://www.steinberg.net/forums/viewtopic.php?p=949087#p949087

As I told you in the other thread:

It’s not random, it depends on the order they are enabled. It happens because Cubase change the ID of the plugin whenever is disconnected. So if you have VST 1. Kontakt, 2. Sine Player, 3. Labs; disable all three and then you enable first Sine, then Kontakt and finally Labs, you will get the order 1. Sine Player, 2. Kontakt and 3. Labs and your MIDI tracks connected to Kontakt and Sine Player will be “missing”, whereas the ones connected with Labs will work as intended. At least, this is what I think it happens (I may be wrong).

In practice, this problem renders the whole enable/disable thing almost useless. And this happens since they invented it… They know, but they don’t solve it (I guess they would have to change all the VST ID thing, which would be A LOT OF work).

I’ve just built a template in this way, hoping to de-activate the instruments to save RAM and loading times, but now I’m getting the same problem… when trying to re-activate the Kontakt instruments, the midi tracks are either disconnected, or arguably worse, routed to the wrong Kontakt. Please fix it Steinberg! My brain can’t handle playing piano out the clarinet track!

I was just back and forth with Cubase support about this and they told me it’s working as intended and they’d pass on my “feature request”. Really hoping that the guy I talked to was mistaken and they’re going to fix this as this issue makes it impractical to disable tracks in my template.

Unfortunately I don’t think this falls into feature request territory, since it persists in cubase 10 and 10.5
I doubt Steinberg had this type of “composer’s” workflow in mind when developing this feature.
Hopefully it can be fixed/added, would be super useful!

Hi,

I agree, this is not feature request, this is a bug.

Did C11 solve it?

Hi,

Unfortunately I can still reproduce it here with Cubase 11.

Really really hope this will be fixed. :slight_smile:
To me to, with big orchestral templates, the enable/disable function become useless.
Pretty please… :pleading_face:

Would be difficult to implement unique ID number for vsti?

1 Like