Missing MIDI Output port in Cubase 8.5

Having an issue with finding the proper MIDI Output port to record MIDI drums. I record MIDI from a Roland TD4 drum kit into Cubase onto a MIDI track and it works well…when Cubase gives me the MIDI output option I need, which is All MIDI Inputs. Sometimes it’s there and sometimes it’s not.

Setup: MIDI cable from the Roland brain to USB input into the PC. When I run Cubase the MIDI Input port shows All MIDI Inputs… but the output port only gives me Microsoft GS Wavetable Synth!

I’ve looked in MIDI Port setup and can’t understand how to get the output I need. I’ve tried all the suggestions on the Forum: restart Cubase with the MIDI device running; rebooting…everything. The attached image shows what I see at startup.

This issue appears randomly, and for no apparent reason. For example, just last week everything was fine. I made no changes to my system or my USB inputs, now I don’t have All MIDI Inputs as an Output port option.

Running Cubase 8.5 Artist on Win 10 64-bit.
CubaseMIDIportOut.jpg

A few ideas that you didn’t try yet…

  • Try a different USB cable. This one could be failing.
  • Try a different UBS port.
  • Don’t connect to a USB port on a USB hub. If absolutely necessary make sure it is a powered hub.

Also, are you sure the computer has recognized the USB connection before starting Cubase. Usually you will hear (or see) some kind of indication on the computer that the connection has been made.

Good luck :slight_smile:

Regards :sunglasses:

Thanks for the reply, Prock!

The MIDI/USB cable is working because on the Transport it shows I’m getting signal when I bang on my Roland kit (see attached image upper right on the Transport meter). Also, this cable was working for me just last week.

I guess the specific problem I’m having is the output routing in the Inspector on the MIDI track (see image again). The input shows All MIDI Inputs, but the output routing only gives me Microsoft GS Wavetable synth or VSL-1. When I’ve recorded MIDI drums in the past (many, many times) the output MIDI routing has always given me All MIDI Inputs as an option…and then the drums record just fine.

I’m thinking there is a basic setup problem I’m missing. When I check VST Connections and go into MIDI the output port only shows Microsoft GS Wavetable also…no option for anything else like USB MIDI Interface or anything.

Make sense?

Sure appreciate any knowledge! :slight_smile:

@Prock…oops forgot to attach the screenshot :unamused:
CubaseMIDIportOut_2.png

I’m not really that familiar with recording drums directly from a midi drum set like the TD4 but… maybe something I list below will help you.

When I record midi using my keyboard (could be drums) I usually record on an “Instrument Track” (not midi track). The input is set to “All MIDI Inputs” and the “Instrument” field (just under the “Input Routing” field) is where I choose what VST sound instrument I want to use.

So when I do record drums from my keyboard, that “Instrument” field is set to “EZDrummer”. I press a key and the resultant sound is whatever percussion instrument is assigned to it. The “Output” for the “Instrument Track” is, by Cubase, defaulted to the main stereo out. Or I could set EZDrummer 2 to record each drum instrument to it’s own track. The output of those tracks are, by Cubase, defaulted to the main stereo out.

I guess, what I am saying here is that I don’t see where (or what) sound module you are using to produce a drum sound. In my example I use the VST EZDrummer 2.

So what are you using to get a drum sound? Setting the output to “All MIDI Inputs” does not seem correct to me?

Regards :sunglasses:

As Prock says All midi inputs can not be an output.

As far as I can see from the manual TD4 only has midi out…there is no midi in.

So you can record while listening the the TD4…but you cannot play back the sounds of the TD4.

So what are you trying to play with the midi output exactly?