Missing MIDI Port on Startup

I have a Motif XS on Machine A but not on Machine B. When I move a project from A to B I get a missing MIDI port error message when opening the project (see image 1):

Image 1 - Missing MIDI Port Error Message

I can click “Ok” or “Cancel” to get by this, but I would like to make this error go away permanently as I have no intention of moving the project back from B to A. Based on reading several posts, I figured I would delete the XS entry in the MIDI ports definition page (Image 2), On the MIDI Remote page (Image 3) or on the External Instruments tab (Image 4).

Image 2 - MIDI Port Setup on Devices Panel

Image 3 - MIDI Remote Page

Image 4 - External Instruments Tab

I don’t see a Motif listing in any of these places. Furthermore, I have cleared all quick control information from each of the tracks. I would just delete the Motif reference if I knew where to find it, but I don’t appear to be looking in the right place even after the different threads I read. One other note is that this does not happen when I open an new empty project on Machine B.

So my question to the group is - how do I make the missing MIDI port message stop showing on project open? Thanks!

BTW, I don’t think it matters, but just in case:
Machine A = Windows 10, Cubase 11 Pro
Machine B = Windows 10, Cubase 12 Pro

Not sure why you would expect to see the port listed as existing somewhere – the dialog complains that it doesn’t exist.

Try selecting a port that exists in that dialog. it doesn’t matter which, really.

My thinking is not that it exists, but rather that it is defined someplace in the project and I need to remove it. I have selected the ports and there is no option there to delete that I can see. Here is what happens when I click over the red lettering:

As far as I can tell, it jut lets me map it to something else, but I don’t see how to delete it.

The point of the dialog is to give a way to replace the port.

A simple search in the manual for missing ports provides the info needed to clear up the misunderstanding.
https://steinberg.help/cubase_pro/v12/en/search.html?searchQuery=missing+ports

It would be to replace it if I wanted to replace it but I don’t. I am trying to remove it since it’ s not on Machine B. I agree that remapping is in the manual as that is part of what I read before posting here, but what I can’t figure out is how to remove it.

Well, if you replace it, it will be removed. The manual author’s logic is a bit shorthand, does follow the definition of “replace”.

Thanks Steve. It could be a workaround although an odd approach if that was the author’s/developer’s intent since it’s usually better to eliminate cruft (i.e., eliminate from the project whatever this is so that space is null) as opposed to plugged with some other stub. I am knee deep in some edits at the moment so will try it in a bit and will post an update once I try it. Thanks for the suggestion!

This is not a workaround, it’s the documented method. Not all values and objects are visible to the user.

Find in the project all the places where it was being used. Some track or device configuration in the project is still pointing to it. If you find it and remove it, be sure to save a new copy of the project.

  1. Check all the tracks that can have MIDI connections. Disconnect…

  2. Check the instrument rack. If it’s showing up here, some track is still trying to use it. Pick a new destination for the track(s) output and remove the instrument from the rack.

  3. Check MIDI device profiles. Some of these are linked directly to a specific MIDI port(s) by name. It’s a DAW setting rather than a project setting, but still worthy of checking. Issues might not show up until a project tries to use the missing device.

  4. Tap F4 and check the external instruments tab. Was the missing MIDI port linked to something here? While this is a DAW setting rather than a project setting, issues might not show up until a project tries to use something from the instrument rack?

  5. If you have any drum maps on tracks check those for extraneous routing. It’s possible to direct individual kit pieces to any instrument/port you like through such maps. They also have default instrument/port settings.

  6. Check for things like Generic Remote maps. These also have MIDI port assignments. (DAW setting, not saved with projects…but might still cause such a report if assigned to missing ports.)

Finally, go to your plugin manager. Check if at one time you might have made an external instrument for it that for whatever reason isn’t showing up in your instrument rack as an option. Seems like when I first ran Cubase 12 a few things involving MIDI ports got renamed, and thus the external instruments (that show up in the instrument rack as if they are plugins) moved out of the rack menu, but where still lurking in the list of plugins. I moved them back to the rack menu and made adjustments. I.E. My Fantom XR ports had a new name with the number 2 appended.

1 Like

Thank you Brian. I think you might be on the right track with the plugin manager idea. I have had the Motif since Cubase 5 or 6 and vaguely remember having to do manual settings on something a long while back that might be causing trouble now as part of the C12 migration. I am away from the machine in question for a bit but will definitely go digging in those areas when I get back and post here as well - thanks again!

I got back to the machine in question, went through all the steps Brian laid out and found the XS entry in the MIDI Device manager.

Thanks for the detailed suggestions @Brian_Roland - the write up helped a ton!