Missing MSVCP140.dll

I have installed Dorico on a new computer and when it attempts to start I get error messages indicating that the following are missing from my computer:


I am instructed to run the installer again, which I have done, to no avail.

I seem to be unable to log on to steinberg.net, so cannot post a “ticket” there.


Many thanksfor help.


Try running the installer as system administrator. If you only have one account on your new computer, right-click on the installer icon and choose “run as administrator” from the menu.

It that doesn’t work, and assuming you meant CONCRT140.dll (not CONCERT140.dll) it looks like you need this:
Select the “x64” version after you click the DOWNLOAD button.

I thought Dorico installed this anyway - maybe your new computer has a different version of it, and Dorico thinks it’s already installed. or something.

Many thanks, Rob!

The second of your suggestions worked.

There were two versions of Visual C ++ 2015, one installed yesterday and one from March. (Plus 2005, 2 x 2008, 2 x 2013 – can I delete these also???)


I would leave them alone. You may have other software packages (including some Microsoft apps!) that still use the earlier versions.

For the small amount of disk space you would free up, it’s not worth the bother of trying to sort out exactly what you need and what you don’t.

Maybe the other “2015” one from March is the 32-bit version, which still be needed for some other software - just guessing!

If you REALLY want to get rid of them, don’t delete them, rename them (and write down exactly what you did!) so you can easily restore them if something else goes unstable.

Dorico insisted that I delete it also (I had already deleted the one that had been installed by Dorico). It was only after I had deleted both of them and reinstalled Dorico that the error messages went away.

Many thanks for your help.


I am also trying to install the trial version of Dorico and getting an error message about missing CONCERT140.dll. I’ve now tried it 3 times, the second time as administrator, the third time after uninstalling everything, updating Windows 10 and reinstalling as administrator. And I am not about to start screwing around with what C++ version is necessary or should be updated or should be erased and replaced etc etc. Just FIX IT so I (and probably a few other prospective customers) can at least INSTALL it or I’m sure we’ll all be moving on.

PS: I did click on the Microsoft link and that was unsuccessful on the basis that C++ was already installed.

Thanks for reporting this, happenedby. Could you please enable Windows Installer logging and then run the installer again, and send me the log file(s) produced from running the Dorico installer to d dot spreadbury at steinberg dot de so that I can ask our installer team to look at what might be going wrong?

I am having the same issue. I followed the link you sent, and all the instructions on the windows help page. Then I ran the installer again, but I didn’t see the log files anywhere. I would appreciate your help.


Sorry for not seeing this post of yours sooner, Vladimir. This thread is quite old and Dorico is now built with a newer version of Visual Studio and so requires a newer version of the Microsoft Universal C++ Runtime. Please make sure you’ve run all available Windows updates, and try installing the latest version of the Microsoft Universal C++ Runtime.

Hello! I’ve got the same problem with my eLicenser (missing msvcp140.dll), but i can not install C++ 2015 because of already installed C++ 2017… And also in the C:\Windows\SysWOW64 there are msvcp140_1.dll. The same deal with VRUNTIME140.dll… I have got the latest update for Windows 10 on PC, i think the problem could had appeared right after this update. Does anybody haveany ideas of this problem fixing ??