Missing plugins [solved]

My sonarworks plugin is all of a sudden gone.
As are all my Tokyo dawn plugs.

I have forced rescan about 100 times, also have specifically told wavelab to scan my programfiles/vstplgins folder, also in programfilsx86

Is this a well documented feature?
How do I get them back?


In the plugin preferences, second tab, you have a button to visualize which plugins have been rejected. Can you find your plugins there?

Yes, they are there.
I have tried clicking them, restarting- nothing.
I have tried to click all of the missing ones (that were there yesterday) restarting-nothing.

I have tried to reinstall sonarworks, restart, nothing.

What could this be? They all work in Pro tools.

I know those are AAX, but everything was fine yesterday…:slight_smile:


If they can’t be loaded, while they could before, this means they depend on some external file that is now missing or changed. IOW, something has changed on your system.

In normal conditions, WaveLab does load your plugins at startup… unless their size of timestamps changed. Or if WaveLab preferences were reset. If you say the plugins have disappears from a day to the other, that means they were evaluated by WaveLab. Could it be they were updated?

BTW, you should not scan programfilesx86 which is for 32 bit plugins, this could create conflicts.

Hmmm, ok, thats strange,
I didn’t update any plug-ins, but still these are gone from one day to the next.
Sonarworks is vital to my workflow, it would be nice to get the Tokyo dawn stuff back, but I have a feeling if I can solve sonarworks, the others will follow.
What should I try next?
Thanks for your time!

Frode Berg
YourSound Mastering

It could help to get diagnostics. Please do this:

  • Click on the File Tab, then on Preferences
  • Now press Alternate and click on the Global button
  • You can now see a tab called “Diagnostics”, at the right side.
    Click on it.
    Now click on “Allow Logging” and “Extreme”
    and in the field “Log Codes”,
    select “Log.PluginScanning”
    (see picture)

    Now, use the procedure to force the rescanning of the sonarworks plugin.

Then launch WaveLab again.

Scanning will create small text files inside the folder:
C:\Users[your name]\AppData\Roaming\Steinberg\WaveLab Pro 9.5\Cache\PluginLogs\

Please show me the contents of the sonarworks file.

Hi, this is the file:

[0070.678.218] Starting!
C:\Users\frode\AppData\Roaming\Steinberg\WaveLab Pro 9.5\Cache\PluginLogs
C:\Program Files (x86)\VSTPlugIns\Sonarworks_Reference4_x86.dll
[0070.678.265] Will call LoadLibrary
[0070.678.640] !!! LoadLibrary Failed
[0070.678.640] Error can’t TVstLibrary
[0070.678.656] Loading OK
[0070.678.656] Will read request
[0070.678.671] Do Request: IsReallyPlugin
[0070.678.687] Will Write Answer: 0
[0070.678.687] Answer Written with Success
[0070.678.703] Request done
[0070.678.703] Will read request
[0070.678.718] Do Request: quit
[0070.678.734] Will Write Answer: 1
[0070.678.750] Answer Written with Success
[0070.678.750] Request done
[0070.678.765] [0070.678.765] Quitting with code 0

The log mentions “Sonarworks_Reference4_x86.dll” which is obviously a 32 bit plugin (from its name), hence that is not compatible with WaveLab. Please use 64 bit plugins.


Thank you so much for taking time!
This is my embarrassing moment, I’m blushin here.
I have though that the VST folder (within programfiles) held the VST2 versions of the plugs, and figured I don’t want wavelab loading them, so after pulling my hair here, I notice I have set it to exclude plugins from that folder. (I thought the programfiles x86 folder hosted the newest VST’s…
Talk about missing the forest for the trees…

So sorry to have taken up your time, thanks again!

I will be loyal to wavelab until version 30.7, then I will retire and spend all my millions made on music production to buy Steinberg and give you a hefty raise!

:blush: :blush: :blush: :blush:

Good :wink: