Missing ports found

Cubase pro 12
I have been getting a screen showing 2 missing ports
Looked in the studio audio system setup and they are not showing in there
How do i get rid of this?

See photos

In your project there are one or several MIDI/Instrument tracks that has a connection setting that is unavailable. By simply connecting those tracks to available MIDI ports and saving the project, that message should not show the next time you open your project.

I have searched in the Project but cannot seem to find any tracks connected to the Missing Ports

Any other suggestions?

How do you rename the first part of the port names above
E.g change JV-80 to something else

So the project does not have a MIDI track named “3- UM-ONE”?

No it does not

Normally, by clicking on image and selecting an existing port.

If they are mapped but the text is incorrect?

If which is mapped, and what text is incorrect?

Can’t you use the dropdown menu to assign something, so the error message stops being triggered? I don’t think there’s any need to find the ports it complains no longer exist.

I will send some new pix to explain when i am on the Studio Pc next

05 Audio Only Project

This is an AUDIO only Cubase Pro 12 project with no MIDI instruments involved
I added a TEST MIDI track and then looked at the Connections (Pic 2)
The ones at the bottom starting KORG KRONOS x61 are correct, the ones above e.g. Fantom-G (ROLAND VK7) are wrong
So how do i get rid of the erroneous ones?
Looking at the PORTS settings pic, they are not there (Pic 1)

Assuming you are on Windows, you have to open Windows Settings → Bluetooth and Devices.
There you should now see the midi ports like Fantom-G etc. You can remove them.

When I look in the Windows Settings I see 2 x UM-ONE ports which is correct (UM-ONE and 2-UM ONE) which are USB to MIDI connections… no other details are displayed for me to select and remove…am I missing a step?

I think it is not possible to connect an audio track to midi out. So there must be at least one midi/instrument track hiding somewhere in your project that has its midi output set to port “3- UM-ONE” (which does not exist in your MIDI port setup). Find the track(s), change the midi out to an existing out port or ‘Not connected’ and the problem goes away.

I was not trying to connect an audio to midi ???
I simply added a MIDI track into the Project and observed the Listed Ports

There are NO MIDI tracks in the Project or MIDI instruments defined (apart from the One MIDI track I added in as the TEST MIDI track) see pic
all the other tracks are AUDIO


These are probably defined MIDI Devices.
Go to menu Studio → More Options → MIDI Device Manager,
then either remove the unwanted entries or at least remove their assigned midi connection.

Ah ok, will do when i am back in the studio again
Will report back

Yes, correct
They were set up there so i removed them
Thanks for the help

1 Like