Missing Ports Out of the Blue! (Internal Soundcard Not Connected?)

Hello everybody,

I’ve run into quite a frustrating problem that I hope reflects more my inexperience than it does the difficulty of the issue at hand.

I was making music on Cubase Elements 12 when all of a sudden I received this “missing ports” popup indicating that the project isn’t connected to my sound card. Because I use a laptop to make music these past months, I’ve simply used my internal soundcard “Speakers (High Definition Audio Device)”, which has worked completely fine.


(As a new user, I’m only allowed to publish one image, so I’ve put the three screenshots that seem to be relevant into one image!)

I’ve no idea why it doesn’t work anymore. I’ve scoured all the other forums to find a solution but no one quite seems to use their built in speakers to make music… (you can tell I’m just starting). I’ve checked my “Studio Setup” area, and it doesn’t appear that I have the option to switch from “No Driver” to my “Speakers (High-Definition Audio Device).

If any of you could please help me, that would be incredibly appreciated – I was quite enjoying the composition process before this popped up!

Thank you!

Hi and welcome to the forum,

I would recommend to use ASIO4ALL driver.

1 Like

Thank you so much, Martin! You’ve saved me from launching my computer out the window, and now I can go back to making music!

Have a wonderful day, and thank you again!