Missing shortcuts

I don’t have the shortcuts for moving hairpins by grid: Cmd-Alt-Left/Right and Shift-Cmd-Alt-Left/Right. I suppose it’s because I have modified my key commands prior to updating to 1.1. I know I can reset key commands and get the defaults (back), but I have customized quite a lot of them, so I’ll rather not do that. I haven’t managed to find them in Preferences. Did I miss them, or are they some of those who can only be edited by fiddling inside the .json file? If the latter, I would appreciate any help on how to do that, since I’m not experienced in working “under the hood” (and a bit nervous to mess things up).
I had the same problem with System Text (Shift-Alt-X), but I could add that manually in Preferences.

Unfortunately that’s correct: those shortcuts are not possible to set in the program because they take parameters that can’t be shown simply in the dialog. These are the significant entries from the default JSON file:

						"EventEdit.DurationLengthen?UseRhythmicGridValue=false": [ "Shift+Alt+Right", "Num+Shift+Alt+Right" ]
						"EventEdit.DurationShorten?UseRhythmicGridValue=false": [ "Shift+Alt+Left", "Num+Shift+Alt+Left" ]
						"EventEdit.DurationLengthen?UseRhythmicGridValue=true": [ "Ctrl+Shift+Alt+Right", "Num+Ctrl+Shift+Alt+Right" ]
						"EventEdit.DurationShorten?UseRhythmicGridValue=true": [ "Ctrl+Shift+Alt+Left", "Num+Ctrl+Shift+Alt+Left" ]

In theory you can paste these into your edited JSON file from /Users/your-username/Library/Application Support/Steinberg/Dorico: find the lines that say:

				"context": "kMusicEditable",
				"shortcuts": [

and paste the above lines directly below the second line shown above.

Copy and paste the whole JSON file into http://www.jsonlint.com to make sure that the JSON file is still valid before you restart Dorico.

Thank you for your help. I found the file. Sorry to bother you again, but I don’t have “kMusicEditable” anywhere.

Right, I guess you wouldn’t, because your shortcuts file pre-dates version 1.1. I think you really would be better off resetting to the defaults and then recreating the changes you want to make, since the structure of the whole thing has changed a fair bit between 1.0.30 and 1.1.

Ok. I’ll do that. Thanks for Your help.

Just to add my experience (on a PC), and confirming the advice to reset Dorico’s Key Commands in 1.1. Luckily I hadn’t set any of my own key commands (yet).

To get the shortcuts Ctrl+Alt+Up/Down arrows to work moving notes up and down octaves I had to disable the Hot Keys in my Intel HD Graphics Control Panel (see attached).

John in Discover Dorico a few days ago showed us how to use Ctrl+Alt+Left/Right arrows to move hairpins and the like left and right by the note length specified in the Rhythm Grid. He mentioned that we might have to Reset Key Commands in the change from Dorico 1.0.30 to Dorico 1.1, which I had to do, finding the reset in Edit>Preferences…>Key Commands (right hand panel). Presumably this was needed in addition to disabling the Intel Hot Keys, as above.

Great to get these working. I’ve used the new shortcuts a few times already.