Mixer bug?

I created a score for saxophone quartet by adding solo players and then entered the music. Upon playback, all quartet parts playback in the mixer’s soprano sax track. The other sax tracks are in the mixer, they just aren’t registering anything. When I mute the soprano sax track, all the saxes mute. When I unmute, all the saxes sound. Is this a bug, or am I misusing something?

All the saxes are on port 1, but each is on a different channel. (If I move a sax to port 2, that sax doesn’t sound.)\

Also, the meter in the track seems WAY behind the actual music, but I chalk that up to an aging computer.

See zipped Dorico project “saxes - mixer issue,” attached. (The music, to credit, is an extract of a marching band arrangement by Ben Lee.)
saxes - mixer issue.zip (572 KB)

If you find the meter seems way behind the music, you might try lowering the buffer size in Edit > Device Setup; provided you have decent audio hardware in your computer you should find that it’s possible to have a pretty small buffer size (e.g. 256 samples or below).

What VST instrument are you using for playback? Normally this kind of problem is caused by using the single stereo output version of a plug-in like Kontakt or using the wrong version of ARIA Player.

I’m using HALion Sonic SE Noisy Soprano Sax (and alto, tenor and bari). (The “Noisy” saxes is what Dorico filled in when choosing Woodwind:Saxophone in the Setup tab.) All the saxes seem to register on the soprano sax channel strip meter, though alto tenor and bari have labelled channel strips (and nothing registers on their meters). I changed to GM saxes. No change in behavior.

I wonder whether you might recently have updated to Dorico 2 and not yet installed the HALion Sonic SE 3 update? Can you try downloading and installing the “Dorico Playback 1” installer from Steinberg Download Assistant, then in your project do Play > Playback Template and reapply the default playback template, “HSSE+HSO (Pro)”? I think that will take care of it.

How did you load the sounds? Did you manually load HALion Sonic SE (HSSE) and then load in all the patches, rather than rely on Dorico’s automatic mapping? If you did it manually then that explains what’s going on. When Dorico automatically loads HALion Sonic SE and its patches, it loads a special configuration of HSSE that ensures each channel has its own audio output. Dorico’s main mixer section is an audio mixer, and so if you have a plugin that mixes all instruments down to a stereo output then Dorico has no way of knowing this. It works best if each MIDI channel is routed to a separate output.

The best way of setting up playback is to apply the default template, as Daniel describes, and then you can change the individual sounds that are loaded.

That did it! I had already updated to Dorico 2 Pro and downloaded Playback 1 and Playback 2. So, as Daniel suggested, I reapplied the “HSSE+HSO (Pro)” template. Now the saxes are metering on their own channel strips!

Not sure how the mess up happened. I did not manually setup the project. (I used Dorico’s setup tab and interface.) I hadn’t messed with the settings in HALion since I started the project before the problems started. I presume the playback template persists across projects and that I had previously mucked up the settings.

Thank you! Thank you, for your help!

I also have a mixer bug, I think, but am not using any special instruments. I am just using Dorico selected alto, bari and tenor sax. When I solo my reference piano track, I get the piano and the bari sax. When I solo the bari sax, I get nothing. I was not able to delete (by pressing the trash can) certain tracks, so there are some ghosts lying around, as well. I need to output just the individual tracks (like just the bari). I had to create a new project and cut and paste the score in there so that there were no other tracks. Is this a bug? Here is the project. Try soloing the Bari Sax, or the piano, for example.
DoricoMixerBugMaybe.zip (967 KB)

Hi Jan, you have messed up the HALion Sonic SE setup somehow. Open the HALion editor window and choose the Mix tab, then you will see that each of the 16 slots is sending their audio to the main output, but instead it should be slot2 to out2, slot3 to out3 and so on.
I don’t know how you changed it by accident, but the most easiest way of fixing this is to reapply the default playback template. Therefore, go to Play Mode and from the menu choose ‘Play > Playback Template’ and in the coming dialog choose ‘HSSE + HSO (Pro)’.
But you can also fix it in the HALion Sonic editor window by reassigning all the outputs of the individual ports.

I’m gathering from this thread the answer is no, but I’m going to ask anyway. Is there a way to get the Dorico mixer to work for non-Halion instruments? I work a lot with Kontakt for percussion (VDL) and Aria Multi for other instruments. Currently all the instruments are controlled by the Ch 1 fader for each engine.


If you use multi-outputs on Kontakt or Aria, you can send each instrument to a separate mixer channel .

The Kontakt process is more complex (or seemed so to me) but is explained in several YouTube videos.

Hello, thank you for the ‘Play > Playback Template’ tip. It did work. However, I am not sure which window is the “HALion editor window” so I can look at and “choose the Mix tab”.
It is not in the manual under HALion editor window, and the manual for HALion doesn’t have that specific description, and there are many windows involved in Play mode. Do you have a picture of this you could post? Thanks so much! I do want to understand this part of the program.


The HALion Mix tab is within the HALion Player itself, and the Output assignments are on the far right for each channel/slot/instrument.

Wow, ok, glad I asked. If you have videos or manuals about this part, I would like to learn more. I will look around, but if you have particular educational resources about controlling everything in this window, that would be great info.

All the best!

If you sent your question to discoverDorico at steinberg dot de perhaps John would discuss it on line in one of his upcoming Discover Dorico live casts (next one via YouTube on Wednesday, April 29, IIRC).