Mixer channel that I can not delete...

Hey, new to cubase user here, with a weird situation. I don’t know how I got it into this state exactly, but I seem to have an extra mixer channel that isn’t linked to a track, although after playing around with this for a while I finally found that it looks like it’s showing up in the upper panel as an ‘automation track’ or something? (Apologies that I am still learning the proper names for things in CuBase).

I can’t figure out how to delete this mixer channel, or the extra automation lane, but I can see that it’s clearly linked to the track next to it. If I duplicate the “OHH” track, it duplicates this ‘ghost channel’ as well, and I get two new channels in the mixer.

Can anyone help me understand what’s happening here? and how to clean this up this extra mixer channel that I don’t want. (I can hide visibility as a workaround, but I’m still trying to learn Cubase and understand better what’s going on here). Thanks!

it*s part of an instrument track
as you can see on the symbol on the left

maybe your instrument has more outputs

Delete the corresponding track in the project Window (may need to turn its visibility on).

If it doesn’t seem to exist in the Project Window toggle its Automation Write button in the MixConsole which should cause it to show up in the Project Window.

But as st10ss implies, you probably want to figure out why it exists before trashing it.

This is the issue… it doesn’t seem to have a corresponding track in the project window. It’s somehow linked to the adjacent instrument track (which is a Groove Agent). I was able to get rid of it by just deleting the adjacent track and re-creating it with the same MIDI. I still want to understand what happened though, if anyone has seen this and can explain it.

Perfectly normal, those are output channels and as explained earlier won’t show up in the arranger if there is no automation on them.

Can you elaborate a little bit? I am pretty new to Cubase. How would I get rid of the mixer channel fader, without having to delete the “parent” track?

Also, do you know how to to get it into this state?

This Part

It seems your instrument had an extra output channel activated, therefore you had an extra mixer channel for that (and an extra automation track belonging to that on the arranger page). To remove that extra mixer channel you then need to deactivate the extra output channel.

Click the little icon shown in the picture and you’ll get a popup window where you can deactivate/activate output channels for the instrument.
output button.PNG

Starsprinkler? No. This just opens other possible instrument swaps, there is no channel output function there.

It is as Starsprinkler says…

Only if you have a single out instrument, then it’s for instrument swaps - but if you have a multi out instrument (like Groove Agent that OP was referring to) then that button changes to “activate outputs” instead…

double post

Ok , I have this with GA 5se , If i have assigned the pads to an output and the preset is swapped , what ever outputs are not being used still show up in the mixer and you can not remove them even if the pads output is put back to the main output ,all i can do is hide the output but can’t delete it

It is not about what is used or jot, itˋs about what outputs are enabled.

Oppsss , I posted before trying this and by doing both of these has worked perfectly , the channel has been disabled and no longer shows up on the mixer ,You live and learn every day no matter how long you’ve been using Qbase :wink:

I never noticed that before, but that’s obviously a bug. That icon shouldn’t be displayed if the instrument only has a single output. If the instrument only has a single output, the region you click on to select an instrument (the region that contains the instrument name) extends all the way to the right of the inspector and no output icon should be displayed.

Aha, it’s a bug… Yes, I thought it didn’t make sense to have one icon/button for two very different things… (and the icon clearly indicates outputs). I hadn’t noticed before either until mr.roos wrote what he wrote and I checked too see what he was talking about… and found out it seemed to work differently depening on the instrument loaded.

But what you write here makes perfectly sense, it’s a bug and the output icon should simply not be shown for single out instruments, only for multi outs. Or, better, the button should be shown but be disabled/no clickable area. That would make it consistent with the output icon/button shown for instruments in the VSTi Track/Rack area in the Right Zone.

I’m still on 10.0.60 by the way, so the bug can’t be new.

Hm, I’ve been away on vacay so I missed this info. Thanks all of you for sorting out my experience vs. yours. I agree it seems a bug, and it’s rather odd that Steinberg opted to have the program create a popup window (in my single VST instrument usage) that left me with a narrow understanding of the icon’s purpose. I guess it’s the case where when you know, then you know. And now I know.