Mixer missing in Cubase

I just recently bought and installed the Cubase 6-.5 version. But I thhink this matter is a thing that matters any of the Cubase versions…I opened a project,opened up the mixer, marked “always on top”, and moved the mixer to a new monitor( I use 3 monitors). What happened was that I just accidentally unmarked “always on top”, and then the mixer just disappeared, and now I can’t even find it… :frowning: Also, even if I designate / assign key commands like for the main mixer to key # 1 on the keyboard, mixer 2 for #2, Mixer 3 for # 3, nothing even happens when I do that…Any of you guys have any ideas what has happened, and how to solve this??

Hey toreleiren,

Try this:
Select your mixer from the menu (or shortcut) this will select it (but off-screen.)
Press . Press M.
Use your four arrow keys to move it back into view.

This works for most windows even other applications I’ve tried.
Best of luck,



This is not Cubase problem, this is Windows problem, I think. I have had lots of “losted window” problems (not In Cubase only), before I switch.

But Cubase can solve it, I hope. Try to tresh preferences. If you have new version and instalation of Cubase, you can’t lost your preferences settings.