Mixer Mute behaviour

I am sorry if I missed anything, I was searching the forum but I didn’t find anything regarding the behaviour of Mute in the mixer in Dorico 4.2 with Noteperformer.

Please see the attached gif.

I am trying to quickly mute all sounds sometimes when I am sketching to not rely too much on playback. I therefore:

  • go to Play Mode
  • press mute on the Output

⇒ all tracks are muted as well

later I want to unmute, to hear my final orchestration. So I:

  • go to Play Mode
  • press the mute button again
  • Output unmutes.
  • I try to hit play
  • No sound
  • I have to unmute all the other tracks seperately.

So I thought, next time I will just hit the global unmute button straight away, which I did. But this unmutes everything except the Output track. So I went to unmute that one, which again triggered a mute for all the other tracks.

2 thoughts:

  • muting the output should not trigger a mute of the tracks. That’s not how other DAWs handle it
  • the mute button should always carry the state and not act as a blind toggle, if the state is passed to other tracks.

As per the NotePerformer user guide, you have to use NotePerformer’s own mixer.

which has no global mute, and the volume knob will not completely mute when turned to 0…

Is this behaviour really linked to Noteperformer? (I have no other sounds installed, not even the Halion SE Sounds, as I usually work without sound or with NP)

There does seem to be something weird going on. If I mute the Output it mutes all of the tracks. If I then unmute one of the tracks then it’ll successfully play back despite the fact that the output still shows as muted.

1 Like

I’ll take a look on Monday…


When you want to unmute all sounds, what if you go to Play Mode, click the mute button on the Output and then click the mute button at the top of the lower panel right after the words Deactivate all?

We’ve already covered this, I think.

I agree that successful playback when the Output is muted is a bug, but my suggestion to click the mute button on the Output followed by the “global unmute button” turns off all of the mutes, which I don’t think was already covered.

That strikes me as a waste of a click, given:

If the bug is fixed so that there is no sound when the Output is muted but the global unmute button continues not to unmute the Output, then it won’t be a waste of a click in the future.

That simply wouldn’t be a fix. In previous versions of Dorico (3.5 for instance) the Deactivate All Mute States and Deactivate All Solo States buttons affect the Output as well as all of the individual faders. For that reason I have to assume that that’s the designed behaviour of those buttons in Dorico 4.

So now you’re describing another bug in Play Mode.

Please read the original post again. It’s pretty clear.

Leo, I have a great deal of respect for you and the help you have given to countless Dorco users, but I don’t know why you found it necessary to attack my initial suggestion in this topic, which merely provided a way to turn off all of the mutes.

I think we’ve already established that (right now) it doesn’t make any difference whether the Output’s mute light is on or off.
Please explain the purpose of turning it off.

This is what I am doing in my video, it’s the second click.

But I agree here.

… this would be another bug to fix.

A fair amount of digital ink has been spilled here, but there’s just a small bug at play: when you click the mute button in the master output channel, Dorico explicitly mutes all of the other plug-in output and MIDI channels, but it forgets to explicitly mute the master output itself, so despite the button being switched on in the UI, the underlying state is out of step. I’ve now fixed this, and it will consequently be OK in future.


Thank you Daniel! Does that mean that the global unmute will also unmute the output channel in the future?

Also: why does the mute button of the output mute all the audio tracks individually, too? This is really something that I am not used to from other DAWs.