MMCSS - Multimedia Class Scheduler Service - how?

Anybody tried changing settings as described here?
http://msdn.microsoft.com/en-us/library/windows/desktop/ms684247(v=vs.85).aspx

Does it work with any sound card?
What values make improvement? Any recommendations?

It doesn’t work with any card, the driver (in this case ASIO) must be programmed for it.

In the same way that VST 2.4 is a requirement for 64 bit plugins, ASIO 2.2 is a requirement for MMCSS.

ok, my card supports Asio 2.2 and I can enable MMCSS from within driver pannel.

Now I would like to increase priority of audio even more. How to do that with registry keys?

In a sentence, you can’t.

MMCSS prioritizes multimedia ahead of general system operations as opposed to audio functions but still allows for regular tasks.

I think it was Freddie H somewhere here who said any further optimization would only be possible depending on how integrated your system components are, which I would add includes the BIOS.

Perhaps we should postpone this thread until after Sept. 19 when the option to support it will first be made available in Cubase Prefs. :question:

“A new “compatibility” switch is now available under Device Setup > Devices > VST. If enabled, the ASIO threads are set to Windows MMCSS mode to improve the overall audio stability.”

Really interesting topic.

Is this windows 10 mmcss problem when using more than 14 logical cores only related to Cubase?
What about ProTools, StudioOne and all the others…? Don’t they have these problems too?
Why did Microsoft change this from 8.1 to 10?

Questions, questions, questions…

According to this article, it looks like this is a more general problem with Windows 10:
https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups