monitoring Amp rack

I am new to Cubase 6 but used 5 studio until recently. i find that I cant monitor Amp rack without activating the little monitor button on the track - i never used this button before and I dont have to activate it for the other amp simulator or any other VST insert. Also the sound when monitoring is not right. To listen to what I have recorded I need to switch the monitor button off again then I can hear the full effect on the track - can anyone tell me what I am doing that is wrong.
Thanks Ken

Firstly…when you say monitor…you mean while playing guitar live yes??

Your soundcard (worth mentioning what it is)may have some kind of direct monitoring option which would pass the clean guitar straight to the outputs & if you press the monitor button on the track you would hear both (but the one with the amp sim would be delayed by whatever your latency might be.

Are you certain that you can monitor other inserts without hitting that button? shouldn’t be able to!

Hi Grim thanks for replying. You are right I cant hear any other VSTs unless I switch the monitor botton on. So assuming that I now have to use the monitor button, which is fine - how do I get rid of the present problem that I get a mixture of the clean sound along with the Amp rack plus latency, bcause as you suggest that is exactly what I am getting.

  1. Your soundcard is passing the direct signal. You need to turn off direct monitoring. You should have a control panel/mixer for the soundcard that will allow you to do this…check your instructions & check back & say whiuch card you’re using if you still have problems.

  2. Now you will have only the amped sound…but the latency delay may be too high to play your guitar live. In which case you should reduce the buffers on your soundcard to give you less latency.
    If you have quite a few plugs on tracks already this may increase latency (plug dependent) so you can also use the “constrain delay compensation” button as well. This just turns off any effects with latency & remember to switch ot back after recording.