More space for clef

This alto clef is jammed up too tight. How does one give it some more air?

If memory serves me correctly, Engraving Options > Spacing Gaps. There should be some options for clefs. Locally you could use the Note Spacing tool in the left panel of Engrave mode to increase the gap between the notes either side of the clef, then the clef probably has a property that allows you to nudge it left or right.

I cant see any properties or options for clef change clefs.

The documentation for the local option Leo mentioned is here, and it mentions that obviously the properties for the clef aren’t available when Note Spacing is activated because you can’t select the clef in that circumstance.