Motorised fader replacement.

I need to replace the Motorised fader on my CC121. This yamaha one looks identical. https://www.thomann.de/gb/yamaha_ls_9motorised_fader_new.htm Can anybody give me any info on if this one will work or what I should be getting.
Thanks

Hi,

Did you purchase this fader ?

Rgds
Martin

Yes… Worked fine, problem solved and good for another 10 years I hope :slight_smile:

Would this one work? Also for LS9

https://www.ebay.com/itm/Alps-100mm-Motorized-Fader-for-Yamaha-M7CL-DM1000-DM2000-01V96-02R96-AW2400-LS9/233007904638?_trkparms=aid%3D1110001%26algo%3DSPLICE.SIM%26ao%3D2%26asc%3D20160323102634%26meid%3D807b33bdd8934a76a0eb785448b56dac%26pid%3D100623%26rk%3D3%26rkt%3D6%26sd%3D233089626449%26itm%3D233007904638%26pmt%3D0%26noa%3D1%26pg%3D2047675&_trksid=p2047675.c100623.m-1

I replaced mine with the same fader in the link earlier and the tracking/calibration is way off fader only moves in a small space in the middle.
I noticed there was a another different LS9 fader on Thomman:
https://www.thomann.de/gb/yamaha_ls_9_01v_motorised_fader.htm?glp=1&gclid=Cj0KCQiA-rj9BRCAARIsANB_4ABHR8Cs1BkwqrDjG6Z8a0PPCGRCwi5OxMGrfyP5162LoXU3vuy7twoaAv-XEALw_wcB
The one i replaced it with was identical to the original apart from it had a rubber dust cover under the actually fader slider.
Did i buy the wrong one?

I replaced mine with the same fader in the link earlier and the tracking/calibration is way off fader only moves in a small space in the middle.
I noticed there was a another different LS9 fader on Thomman:
https://www.thomann.de/gb/yamaha_ls_9_01v_motorised_fader.htm?glp=1&gclid=Cj0KCQiA-rj9BRCAARIsANB_4ABHR8Cs1BkwqrDjG6Z8a0PPCGRCwi5OxMGrfyP5162LoXU3vuy7twoaAv-XEALw_wcB
The one i replaced it with was identical to the original apart from it had a rubber dust cover under the actually fader slider.
Did i buy the wrong one?


It’s a long time ago now but I’m sure the one I bought did not have a rubber dust cover and I believe was the cheaper of the two. I hope I did not link you to the incorrect fader, if so I’m really sorry. Just for info mine is still working as new. Maybe thomann will let you swap, their service has always been good for me. Let me know how you get on.

Ok many thanks for the reply.
I figured that was probably the case. I’ll see if i can get it swapped although it’s not a big deal buying the other one as it’s a hell of a lot cheaper than replacing the whole unit :sunglasses:

I’m pretty sure that both those faders are the same

the difference is the dust cover on the newer unit.

Maybe defective fader then or i damaged the circuit board. Haven’t had chance to look into it again yet