MOTU 828 audio latency problem

Hi Guys
I have just bought a MOTU 828 Mk3 audio firewire interface.
I have installed all the drivers ok and it plays back fine.
My problem is that I have a Huge latency problem when trying to record audio into Cubase 4 studio.
I have tried adjusting the buffers down but it is still dreadful - on the the device set up we are talking of 24ms of latency.
I was told that the MOTU gives zero latency so I am baffled by this.
My operating system is Windows XP home Service pack 3 - 2gb RAM - Pentium 4 3.6 processor and 500GB hardrive.
I use Halion and Groove Agent 3 for my midi and drum tracks but when I try to record audio - for example an acoustic guitar the audio track is way out of time with the midi tracks.
If I enable direct monitoring there is no latency on playing the instrument but the audio track still does not record in time (on the beat for example)
I have the same problem whhen using an M Audio USB midi keyboard controller - everything I record is off beat and out of time compared to what I actually played in the performance. If I look at the Piano roll you can see that all the notes I played on the keyboard are out of beat - I have even tried playing bang on the beat one note at a time to test the problem and hey presto there it is - in full view - the notes recorded off beat.
I have also tried disabling my computer sound card (Realtek) completely out of the system so there is no conflict.
I have a lot of musical work to do and this is simply draining my creativity - any ideas people??
Many Many thanks if you have. Regards Steve. :cry:

Are you sure you have selected the right ASIO driver in Devices | Device Setup … | VST Audio Subsystem?

You should select MOTU’s native ASIO driver. NOT any one of the following:

  • ASIO DirectX
  • ASIO Multimedia
  • Generic Low Latency ASIO

I’ve just been trying to find solutions to this very same situation.
I decided to get an 828 Mk3 hybrid to work with Yosemiti, but on setting it up with Cubase 8, I have a big midi and audio Latency problem.
Although the Buffer: size 256, latency: 6.689, Asio: Motu 828mk3, all the latest motu Drivers for OSX10.10.
Is there something with mackie (hui) I should be doing? hopefully it’s something basic.
In over 15 years of working with Cubase, I’ve never had this issue.
I’d appreciate help. Thanks

Further experimenting, I found the latency problem is only with Cubase 8. When I use Cubase 7 all is fine again even though it has the same audio and midi settings now with the new 828. The only difference being C7 is 32bit and C8 64 bit. Oh well.
The other phenomena is that when I save a test song in C8 it opens up in C7. Time for a beer I think.