Move certain notes to a stave above (piano's grand staff)

Hi, I’m trying to record an idea and there’s no way it can give me something good. I changed delay, quantizations, played very slow and precise along with the metronome, but it always give me a very bad starting point. Anyways… Now I’m trying to clean up this and I’m trying to select these notes in red only and move them to the staff above (clave de Sol). any tips on how to do it? I can’t ever select them only without selecting all of them. thanks a lot.

Use click-and-drag to marquee select only those notes, then Alt-N.

Some of your settings are surely wrong. Have you turned off tuplets?

Or it could be that you have some latency offset issues. Have you checked that latency is aligned?

Thanks but that was the first thing I did. I guess that the problem is that the ties are making mandatory select the whole thing and can’t select only those?

I don’t feel any delay at all and played already with delay values in the MIDI latency compensation options ( but no different results), what you mean with align the delay? How can I check this? I’ll try to uncheck detect tripplets, but I do have them?!

thanks a lot for any help. I’d love to get this right.

Dorico should produce much more idiomatic keyboard notation than that by default. If you select just a rest in the RH staff and start recording, Dorico will automatically split the music between both staves (at a dynamic split point), and also automatically assign music into different voices as needed.

I’ll try now to play without the sustain pedal to see if I get a better result.

Sustain pedal doesn’t make a difference in this case, really.

When you record a single repeated note, matched exactly to the metronome, do you get clean quarter notes? You can check this further by selecting one of the notes and checking the properties panel for start and end offsets. There are (I think) 480 units in a quarter note. If you’re playing as precisely as possible, this will help you check your offsets.

What is your quantization set to?

hi @dan_kreider I did it and got this:

and the offset is this:

i’m not sure what this means. Again many thanks for the help.

I did it and can’t get the notes distributed between the two staves… anything else I can try?

I only can achieve something useful when recording if I leave the option to keep the preserve note positions checked. but I still have the issue that It’s no being split between staves the notes. see below my best short so far. thanks! @dspreadbury

That’s a much less good result than I would expect. If you try to play a very simple scale directly on the click, do you find that the notated result is clean and as you would expect?

thanks @dspreadbury , If you see my earlier messages I sent a screeshot of a similar exercise. Direct link to the comment here: Move certain notes to a stave above (piano's grand staff) - #7 by pabluez

Any thoughts on why this is happening then? @dspreadbury
I’d love to get this as it should. I’m running Dorico 5.1 Pro. Thanks a lot.

Daniel has a lot of demands on his time, please be patient!

Hi @pabluez , besides of the above comments:

For the Rhythm:
First of all consider to experiment recording a very simple one line rhythm, setting the midi (recording) quantization setting (see below) as 8 or 16 notes, no tuplets and no grace notes, and changing your midi input latency compensation. (I have set for example my to 120ms, so that the notes that I record are correctly aligned with the metronome, it depends on your hardware configuration):

I suggest also (for the Rhythm) that you set your midi (recording) quantization settings differently, adapting them to your desired results.

Under Preferences/Play/Quantization try changing the settings accordingly to what you need to record, before you record:

You can also requantize after the recording:
-select the desired passage
-menu Edit/Requantize… and change the setting accordingly (here for example if your fastest rhythm is 8 notes, without tuplets, and without grace notes…)

It seems in general that your recording (I mean the intended performance, not what, due to quantization settings, Dorico notated) contains both different tuplets and grace notes. Consider (due to latency problems) that maybe another option would be, for complex passages, to record them in a somehow simpler way (without complex tuplets or grace notes) and edit your music after the recording.
Dorico editing capabilities are very deep and powerful and sometimes it is faster to edit after the fact, than trying to record all the nuances…

It would be helpful, to help you further, to see a sketch (also handwritten) of what you wanted to appear in Bar 42-44 to see what the actual music should be.

Also consider reducing the latency of your sound card (this reduces the time that passes between the playing of a note and the sound that you hear):
menu Edit/Device Setup/Device Control Panel…
And of course try out different virtual instruments for your Piano: for example I experimented just now with Vienna Synchronized Steinway D, and with a buffer of 32 (in Device Control Panel, and a midi input latency of 80ms (in the Preferences of Dorico) I have optimal results…

1 Like

Hi @Christian_R , thank you for your message. I’ve tried up to 40ms latency when I started to get worse results. Also tried to uncheck tuplets, grace notes and every single note value length available. It’s hard to record right hand and left hand separatedly because it’s a transition like free solo (but that I can repeat with metronome behind). but It’s possible and I’ll try this. I’ve tried to record certainly 100 times no exageration with different settings but never above 40ms, I’ll try to start on the 80ms next time and go until 200ms.

As device I use a Celviano Grand Hybrid GP-300 as midi device and a Scarlett Focusrite interface (with Focusrite USB ASIO driver setup in Dorico and selected in the device list).

I’ll try to record today a video of me trying to record this passage and share here. I’m sure I’m doing something wrong and will be easier to get help from this great community and Steinberg.

I’m thinking that Dorico doesn’t like the “free” way (even though repeatable exactly as is with a metronome) of this passage. So I’m okay with results I’m getting when I select the option “preserve the notes position”, but what doesn’t help is that it’s not split between staves. So it create all in the same G clef, with lots of ties that can’t get selected to push down the the F clef. If only found a way to fix this, I’d probably be okay with the results.

Consider also the possibility of setting negative values.

Ok, I recorded a video of me trying to get this to work. @dspreadbury @Christian_R . Any tip will be very welcome. Thanks a lot in advance.

Hi @pabluez thank you for the video.
Your playing contains very complex (and free) rubato that i think is not exactly for what the Dorico live recording is designed for, unless your playing is very but I mean very precise, or you want to invest some times re-quantizing portion of your music and using the midi editing functionalities (moving notes to other staves, voices assignments, and menu Write/Edit duration…)

Here you would be, in my opinion, better served in a DAW:
-make a Beat Mapping (Logic) or Warp Grid (Cubase) to let the program know where the beats correspond to witch notes, (for such complex and irregular rhythms).
(I really hope that in future it will be some sort of beat mapping in Dorico: it is a sort of quantize on steroids :slight_smile: where you not only decide how long and how organized the rhythms are but also when a particular beat starts!)
-Then export as midi and polish in Dorico.
Do you have any of this DAWs? (I am sure that also in other DAW there is some sort of beat mapping.

But in general to be sure to have the best settings in Dorico (for simpler recordings), did you follow our suggestions to setup the settings and record very simple rhythm and adjust the settings till you have good results?

1 Like

Hi Christian, yah, I’ve played hundreds of times literally, very precisely many times (not for the video which was recorded in a hurry) that’s why I think it’s not a question of playing with precision. this passage is on purpose like it is because it’s a transition to a change in time between Theme A and B. But it ca be played against metronome, as I plaued in the video many times while trying different settings.

I have Cubase Elements 13 in terms of DAW but don’t know how to use yet most of the features. I’ll look into the one you mentioned. And yes, I did those tests with very simple passage just to make sure Dorico settings were okay. Thanks a lot christian, for the help.

When I keep the “preserve notes positions” I have at least all the notes and a 90% correct rythm, meaning a very good starting point. But the notation generated is very difficult to fix. things like the same tuplet split in different voices? like this below that I don’t understand how to split and fix.


Hi @pabluez besides the other suggestions, what I can make is: send me a midi of your recording as Dorico file (maybe 4 bars) and a handwritten music (picture) of what you expect it to be notated. I will be happy to send you then a possible workflow to adjust the notation.