Move Multiple Clips Left In A Montage?

Possible Noob question.

Driving me nuts. How does one grab several clips and CD markers en masse and nudge them all left a few ticks?

Select the clips you want to move. Hold Shift and tap - (minus on the number pad) to nudge left. Hold Shift and tap + (plus) to nudge right. Make sure the markers are bound to the clips first.

You can set the default nudge in Montage Preferences. Or Nudge is under Edit.

PG, strangely I can’t get the Nudge to auto select the Clips for nudging if I select the clips by drawing a selection around them. Only if I select the clips the normal way.

Indeed. I will have to check this.

Philippe

I must be dumber than a bag o’ hammers but I can’t get it to work. I can get it to work by moving the mouse under the centre line until the cursor changes to a two-way arrow and dragging—no problem. But ‘nudge’ via key command? No dice.

Tried re-assigning key command in Preferences to another open keystroke. Driving me kinda nuts.

Using the mouse for this kind of fine-grained motion is a real blood pressure destroyer.

How bout if you set a higher Nudge value in Audio Montage Preferences (on the All Audio Montages tab), just to see if it’s working. Like 1 second. So it’s more noticeable.

Also, how are you selecting the clips? Because the auto-select nudge target is not auto-selecting “clip” as the target if you use the “lasso” to select the clips (my message above). You could go to Edit/Nudge/Target and hard set “clip position”.

So I am selecting clips by clicking on one clip to highlight, then right clicking and from the popdown menu selecting ‘Select Clips Located After Cursor’.

Again, this works fine with mouse drag. No go with Nudge key command of - key. I tried with numlock on or off.

Maybe I misunderstand concept?

Don’t think you misunderstand the concept.

That selection method works ok here. You’re using Shift and number pad + - keys, right? (NumLock makes no difference here).

Did you check Edit/Nudge/Target for auto or clip position? And you’re zoomed in and sure they’re not moving?

Don’t understand what that means, sorry.

—JC

On the ribbon above the montage, Edit button, then Nudge, then Target

Got it. Still no luck. Maybe it’s because I have a fancy schmancy CM Storm Trigger keyboard? I dunno. Nudge works fine in Cubase. No other key commands are a problem in WL. Using Windows 10 ‘Creator’.

Yeah I don’t have a fancy keyboard.

You’re sure the clips aren’t moving? The Nudge value in Montage Preferences might be very small. I didn’t think things were moving until I upped that.

And the shortcut is back to Shift + and Shift - in Shortcut Preferences?

Maybe somebody else can reproduce what you’re seeing (no activity), based on their keyboard, but I think it’s more likely a case of trying to get it to obviously work, consistently, by changing values (Montage Prefs - Nudge value. and Edit/Nudge/Target - Auto Select vs. Clip Position) and trial and error. It was for me.

You’re a genius. I’m gonna call this an ‘Import bug’. I think it’s solved.

I went to the Nudge Value and it was like 6MS. and it did NOTHING. Swear to God. So I kept bumping it in frustration. And when it got to like to 2 seconds… It started working. And then I dropped it back down to as low as it could go and I noticed… “Hey… it doesn’t go below 10”.

So now it’s at 10 and it’s fine.

My guess is that when I upgraded to WL9 I had a hella time with the import of settings until PG helped me with a registry fix or deleting a file, I believe. I think this is just some detritus from that.

Anyhoo… never woulda figured it out without your persistence.

THANK YOU, SIR!

—JC



I’m not a genius. I never woulda thought it could be an out-of-range value. But I’m glad you got it working.

Oh… you’re a genius all right. Say it a few times. Feels good, no? :smiley:

Responsive too.

That’s actually 90% of the battle with WL. Most of the time when I get angry with WL it’s because it does sooooooooooooooooo much ‘stuff’. One often needs that slight bit of hand holding or ‘nudge’ or just the sense that someone else gives a shit (or at least -I- do) to change one’s attitude. After a few months with WL9 I absolutely love it. For -me-, the logic is about 1000% better than WL7. It literally does everything I could want (well, except for Spectral Editing multiple blobs like Izotope RX) completely intuitively. But it takes a while to get with the program—because WL =is= such a unique UI. Without guys like you working the forum, I would -never- stick with it and gain any fluency. So thanks again.

So that would be 10 milliseconds then as lowest limit?

Correct. 10ms seems to be the lower limit of the selector. I have since bumped it up to 20ms as that was better for my needs.