mp3 export adding silence

Ok, so I’m working on some loop tracks for a video game. When I export a wav, it loops seamlessly. But when I export an mp3, it seems to add a tiny bit of silence at the end, thus it stutters when it loops. Anyone know what’s going on? This actually happens to me with Logic as well, so it must have something to do with the mp3 export settings.

Actually, I think I figured out the issue - LAME mp3 encoding seems to add “padding” at the start and end of an audio track. There doesn’t seem to be any way around it:

So for anyone doing loops, wav is the way to go. If they are really adamant on saving space, OGG files also loop seamlessly.