mp3 export cuts file length

Hey guys!

I did a batch export from several wav files to mp3. The Problem is, all the mp3 files are cut at the end.
It seems like Wavelab is cutting the “silence”, but I need the mp3 files in the absolute length of the wav files…

What’s going wrong here?

thanks in advance

Have you activated these options?
2018-06-07_18-29-08.png
Did you check the length inside WaveLab?

hi PG,
yes I activated these options.
no, just checked the complete duration of all files in the explorer and also checked it via Cubase (see attachment)

can you re-produce this issue on your system?
it also happens when I just do a single mp3 export / save as…
the mp3 is always shorter than the original wav…

I can’t reproduce. Maybe it depends on the settings you use. I verify the length in WaveLab, by reopening the mp3, and not with another software.
By original design, an mp3 quantify the length of an an audio file. By activating the option I mentioned, a decoder that supports these option, can recover the exact length.
However, when I look at your cubase picture, the difference of length seems big, hence the problem must be elsewhere.

ok, the length of the mp3 measured in WaveLab is equal to the wav. So everything should be fine.
But where comes this bug from? All in all I have 190 Files, when I check the total length in Win Explorer, it differs over a minute… total length of all wavs is 12h 28m 32s, of all mp3s it is 12h 27m 0s. And why does Cubase then “cut” the end of the mp3 file when importing it, so it is ovious shorter than the original wav?

You could try making the VBR MP3’s again, using the checkbox selections PG suggested, and Fraunhofer VBR encoding (not LAME VBR). Then you could see if they appear right in Cubase and Windows Explorer. It’s probably because of the (lack of) VBR headers in the MP3 files you made.

Or use CBR instead of VBR. Then you could use LAME. (Wavelab doesn’t put VBR headers in LAME VBR).

Hi, I used the FH encoder with CBR @128kbit.
I also activated the checkboxes PG posted. The same thing occurs when I directly export a wav/mp3 out of Cubase and import it again. The wav file then has the correct length, mp3 is shorter!!! Samplerate of files and session are equal…
Maybe I give the VBR a try.

thx

Hi,

Sounds more like a Cubase problem !
Check with the Cubase forum as well

MP3 is tricky with Header and Footer
but the time should be same I think !

https://www.datavoyage.com/mpgscript/mpeghdr.htm

regards S-EH