mp3 import cuts file length

Hi guys!

When I do an audio export in wav (44.1kHz, 16bit) and mp3 (44.1kHz, 128kbit), the compiled files have different file lengths after importing them again in Cubase Pro 8.5.30. The mp3 is to short (see attachment).

But when i measure the file length of the exported audio files in WaveLab, the wav and mp3 file have both exactly the same length as it should be…
What’s going wrong here? Is there an import option in Cubase for mp3 files (didn’t find any preference)? Or is this an other problem related to the file format of mp3 (due to compression or something else…??)?


I’m not sure but, I read somewhere that this is cause by the sample rate(?).

Regardless, I would try moving the end marker a bit more to the right to catch the whole file. Then cut it if necessary.

Regards. :sunglasses:

mmhhh… but I think the problem is the import. The exported files have exactly the same length.
Files are 44.1 and the session is also 44.1, so why should be there any problmes with the sample rate while / after importing?
Thanks for your advice, but I don’t want to work around, in my opinion, this should work in a “pro” DAW. :smiley:

I agree that it should work with no issue. But, I have seen this same thing reported a few times recently. Search the forum for what was discussed and fix (if any).

My use of the term “sample rate” is probably wrong. My searching seems to bring up using a higher latency setting (buffer size). Who knows… again, search the forum if no one replies.

Regards. :sunglasses:

I am having the same problem. When I import the mp3 into another project the last 7 seconds are cutoff, but the files on its own is fine. Any updates on this?

imported mp3 always is too long and wrong startpoint. Big problem when importing mp3 from other DAWs and working further on arrangement in Cubase.
Wav import is correct length. No problem in Logic and Ableton Live.
please fix this asap.

This appears to be fixed in Cubase 10(.5).

Just tested it and it seems perfect now.

Hello, I have the same problem. Cubase 7.5.40. All preferences are correct. When i’m trying to make a loop in DAW - its perfect. I export file, then import it back to Cubase and it’s croped. I have no idea what is wrong. It happens mostly with mp3 but sometimes with Wav too. Mp3 files import cuts very hard, sometimes up to second. Any solutions guys?

Same here with Cubase Pro 10.5.20.

Confirmed. :frowning:
If it ain’t broken, don’t fix it!