Mp3 incompatibility

Hi guys,

Normally cubase converts the mp3 on import. But recently I’ve been getting this error message instead:

"Errors on importing media

Recording.mp3 Error: Medium type not supported or invalid medium!"

Please Help!


Isn’t the file corrupted? Where does the file come from?

Well, it plays fine in windows media player… so I don’t think it’s corrupted?? Is there another way to tell?

The file come from a vocal sample that has been pitched down using autopitch on my windows phone.


Did you try to import another file from this source?

I’m having the same issue with Cubase 10.5. Running a UR22 interface and 2015 MacBook Pro. Been able to import mp3’s for a long time. Now all the sudden I’m getting the same message.
“Errors on importing media:
[insert name of file].mp3
Error: Medium type not supported or invalid medium!”

Haven’t made any changes to my system, and the same mp3 files will open and play just fine. Tried about 4 different mp3 files. Don’t understand why it always worked and now it doesn’t. Any guidance would be greatly appreciated.