MPK249 script - sustain pedal


I noticed that the MPK249 script is not correct for the sustain pedal. It mutes the first track and It’s impossible to bind It correctly (I tried but It doesn’t work). Is there a manual solution or does It need a patch ?

thanks !

1 Like

Hi and welcome to the forum,

Make sure, you have no Mackie Control Device enabled in the Studio Setup, please.


Oh It could be the reason ? :open_mouth: I’ll check that when I’ll come back house ! I have not any Mackie hardware but I’ll check !

(Sorry if my english is bad, I’m French and doing my best x)

Make sure you have the latest v.12.0.52
Thank you for reporting your results/findings.

Other suggestions on the same question found here:


The root cause is that the MPK249 Cubase preset “10 Cubase” uses the same MIDI message for the button S1 (Control Bank A) as the MIDI standard specifies for the sustain pedal: 0xB0 0x40 0x7F.

The following image illustrates the problem.
First two rows: pressing S1 two times with preset “10 Cubase”
Middle two rows: pressing and releasing the sustain pedal
Last two rows: pressing S1 two times with preset “7 Reason”

The code in the window behind is part of the MIDI remote implementation.

The following works for me.

On the MPK249, go to edit mode and change the CC number for switch 1-16 from 64 to 32, and the CC number for switch 17-24 from 65 to 33.

On the PC, replace 0x40 with 0x20 and 0x41 with 0x21 in the script akai_mpk249.js.
In my case, the file was located in “C:\Program Files\Steinberg\Cubase 12\midiremote_factory_scripts\Public\akai\mpk249”
in the “script folder” C:\Users\sunnegardh\Documents\Steinberg\Cubase\MIDI Remote\Driver Scripts\Public\akai\mpk249. The script in the “script folder” kept getting overwritten, so I changed both files.


@Johan_Sunnegaardh You have now saved me TWICE with this post. This should be a sticky somewhere. Thanks so much for taking the time to explain the reason and the solution. Really very much appreciated. :hugs:

1 Like

Thank you. This issue affected my AKAI MPK261 as well. Also, for others experiencing this problem and who apply this fix, check which jack your foot switch is plugged into. The MPK261 has 2 foot switch jacks for sustain (and 1 for expression pedal). This fix only works with one of the foot pedal jacks.

1 Like


Mackie Control Protocol is using MIDI CC64 (Sustain) to Mute the 1st channel of the given bank.

So if the hardware uses Mackie Control and sends the Sustain Pedal MIDI Message over the same MIDI Port as the Mackie messages, this happens.

The hardware vendor should make sure, the Sustain Pedal is using the same MIDI Port, as the keyboard and PitchBend/Modulation wheels in this case.

For the user, the only solution is to disable the Mackie Control in Cubase.

Thanks for the life saver info! Couldn’t have figured it out on my own.