Multi-Bar Rests with Chord Symbols hidden

I’m not sure if this qualifies as an issue or a feature request, so I’ve tagged both topics. To me it’s an issue, but it might be something that’s built in to the code as a failsafe (in which case I’d love to request the ability to override it.)

I am working on a rather large volume of charts for strings & horns accompanying a cover band, and for each arrangement the client has requested a rhythm-section lead sheet with chord symbols to go along with the score. By the nature of this style of arranging, there are obviously large swaths of material where the strings & horns are completely tacet, but I need chords & slashes on the rhythm section chart, so I remove the rhythm section staff from the full score before I begin engraving, then enable multi-bar rests for the full score in layout options.

Ideally I’d like to see something like this

The issue is: any time there is a chord change, it creates a break in the multi-bar rests in the score. So on a tune where there are one or two chords per bar, consolidating multi-bar rests basically does nothing. This happens even after manually hiding the chord symbols in the properties panel

In a part layout (as opposed to a score), manually hiding the chord symbols in properties allows the multi-bar rests to consolidate as they should. It’s only in the score that it doesn’t seem to be doing what it’s supposed to (in my opinion).

I attempted a bit of a workaround as described below, but ended up with a different version of the same problem:

  1. Layout Options>Full Score>Show chord symbols above specific players’ staves
  2. Set Violin 1 chord symbols to “show in full score only” and “show in chord symbol & slash regions”
  3. Create chord symbol regions only on sections where the ensemble is playing

Now the multi-bar rests appear as desired in the score, but will not consolidate in the Violin 1 part if they are inside a chord symbol region. And yes, that scenario does happen if, for example, cellos are soli for 8 bars in a verse before violins come in. Again, chord symbols are manually hidden in the part, nothing is in the bars of rest, but still won’t condense into a multi-bar rest.

(note how Verse 1 is outside the chord symbol region and behaves as expected, whereas Verse 2 does not)

As I mentioned above, it’s not completely clear to me if this is actually an issue with the software or if it’s something intentional to keep multi-bar rests from popping up where you don’t want them, but if it’s not an issue, I’d like to humbly request one of the following in a future update:

  • An option to ignore chord symbols when splitting multi-bar rests OR
  • A command to manually create multi-bar rests (and by extension, hide any system objects inside the selection)

Or if I am totally overthinking this and any of you other super-users can give me a simpler solution to get exactly what I need out of the current version, please hit me with your best ideas!

Thanks in advance

As far as I know your 3-step method above is the best way to accomplish it in Dorico.