Multi core processing in Cubase studio 4

Hey folks i’m new here even though i’ve used Cubase for years. I recently bought a new pc with an Intel i5 760 2.8Ghz processor 8GB of ram and Windows 7 64bit. I initially installed the newest 64 bit version of cubase but noticed that there was an unacceptable amount of asio cpu usage in the vst performance window, something ridiculous like 70% with just a couple of audio tracks and bundled cubase effects plug ins that my single core pentium 4 2.3Ghz on XP with 1 GB of ram had no problem with. I was already aware of the issue that it may be to do with the bridging process of using 32 bit plug ins within a 64 bit host that puts extra prussure on the cpu. I found this to be an unacceptable rise in cpu usage for me so I re installed the 32 bit version of cubase 4 so there would be no issues or conflicts between 32 and 64 bit plug ins (i only use the effects plug in that come with cubase by the way). Everything seemed much better regarding cpu usage but for some reason while I was changing settings I uncheked the multi processing box in the device manager just to see how much the cpu usage would go up by when not using all the core’s. Imagine my surprise when it went down!!! Can someone please explain to my why with the multi processing tab unchecked and not taking advantage of the multicore processer the asio cpu usage on a medium sized song that I loaded with a fair amount of plug ins would average around 20%, yet when I tick the multi processing box to take full advantage of the 4 core’s the asio cpu usage jumps up to an average of 35% and sometimes hits as high as just over 40% with the same song? Have I wasted my time buying a quad core pc while using cubase 4? My soundcard is an M Audio delta 66 that worked like a dream on my pentium xp PC and appears to be fine on the window 7 PC. The only other software I use apart from cubase is kontakt 3. I know Cubase studio 4 is not officially supported with windows 7 and I am probably going to upgrade to Cubase 6 when I can afford it but is there anything I can do in the meantime? Any help with this or an explanation as to why this is happening would be much appreciated
Thanks in advance
P.S If this issue has been addressed elsewhere then please accept my appologies

Nice avatar, beautiful plumage! Ya, but that’s not helpful eh! :wink:

Try going over to and do a search, this was addressed extensively on the old forum. I was just trying to search the knowledge base on this, no hits yet.


Cheers. I will do. I did see the old forum but thought I’d try on the newset one first. They are a nice pair of breasticles aren’t they? Unfortunately they are not mine. Although I do have a savage pair of man boobs though. haha Thanks for the help

I just went back for a look and seems you cannot search… fek! There is the knowledgebase, but that seems to be hard to search unless you can nail the correct term.

Someone here should pipe up with the goods soon enough - sorry! I’ve not had the same trouble you’re indicating…

Multi-processing is for multiple physical CPU’s not cores. Some plugs don’t play nice with it checked. Re: the CPU spikes, did you try trashing Prefs? Sticky above tells how. J-Bridge is what people are using instead of Steiny’s bit bridge. It’s cheap as chips.

I can understand that maybe the feature is indeed intended for actual multiple cpu’s not just core’s, but if your right then how come when i use cubase 4 with my old single core pc the multi processing box is greyed out, but when using it on the quad core pc the box is available to check or uncheck? Surely if it wasn’t meant for multiple core’s it wouldn’t suddenly become available on a multi core machine? It could be the sound card as i have been aware of issues with high cpu spikes with certain m audio cards. Something tells me it’s not that though as that was more to do within 64 bit versions of cubase and mine aren’t just random spikes it’s constant heavy usage on the cpu. Thanks for your thoughts. Any more help or clarification from anyone would be amazing. Thank you for your help so far guys.

i am also very interested to know how Cubase 4 handles multicore CPUs. i just installed win7 64 with 32 bit C4 and plugins on a i5 750 quad core with 8 GB of ram (i know 32bit wont use all of it) and it seems a project i loaded is using more ASIO power than my old XP machine with only 2GB of ram.

also, where do i find the check box for the ‘mulitprocessor’?


Hey Dean
It’s probably the same problem as mine by the sounds of things and your system is very similar to mine. Go into the devices menu, then device setup, then vst audio system (…i think!!! i’m doing this from memory). If your system is anything like mine then the presence of multiple cores should mean the multi processing box is ticked by default. Try loading the same project you had up before and take a note of the average asio cpu usage percentage for the project or take a note of the percentage on a specific bit of the song where it’s pretty stable then un check the multi processing box and play the song at the same place. I bet you the asio usage goes down by about 15 to 20%. Seems to me to be a little strange it works more efficiently not using all the cores. This seems like a common problem that no one can clear up 100% as to why this is or what’s causing it. Maybe mashedmitten is right and it’s meant for actual physical cpu’s and not cores. But if that is the case then why was the box greyed out and not even an option on my single core machine but is now an option for me to check or un check on my quad core machine. I might email someone at steinberg about this. See if they can shed any light on the subject. I’ll do a bit more digging online though first.
Cheers guys

i must be really stupid. when i read this post, my first instinct was to go to the menu you mentioned yet, i didn’t see the multiprocessor box. i am not at my studio at the moment so guess i will have to quadruple check. :smiley: i got on here to post a very similar topic and there you were…
ya, i was pretty shocked as today was the first day i was able to try the new computer with an old project and was bummed with the results so far. Steinys site says you can run a 32 bit Cubase in a 64 bit environment and utilize up to around 6GB of ram (roughly 2GB for win7 while a 32 bit program is looking for up to four). not being a computer whiz kid, i thought the extra ram might help bring the meter down in C4.
if you have any more news or know for sure where the multiprocessor box is, please let me know.
here’s hoping C6 will be much better with these issues (if it ever gets to me :unamused: )