Multi core settings and ASIO gaurd

Hi all I am sure there are many threads for this and if I can learn something from them please steer me there. I am using a UAD Apollo and Also an ANtelope audio 32+ and I don’t think I am getting the performance I should from these 2 units. That improves when I turn off multi-core but of course as the project grows that creates its own problems. I am Win10 on a Prime X299 board with a thunderbolt. before people tell me its the thunderbolt drivers it’s not! I use PT and Studio One on the same system and they work well sub 1ms latency 128 buffer. but with Cubase, I have to crank it to 256 and I get 2.5ms at best. With mutli core activated. But the moment I have that turned on I get these cycled clicks appearing and cracks and pops when I record! this is an I9 system with 128gig and an SSD raid. Its a fast system but for recording with Cubase its sucking the big one right now and as I said Studio One and PT are rocking! I am on the latest CD BIOS is all good the machine is running like a dream with everything else so it must be a Cubase issue. Does anybody have any suggestions.

let these knowledgeable SB forum folks here know what Cubase version you are on. The initial release of Cubase 10.5 had an issue when there were disabled or muted tracks, or something like that was causing high CPU rates. It may be important what Cubase version and build you are on. I use 2 Apollos no issues now but also had some problems on that first version of Cubase 10.5 on my PC there is a fixed Cubase version 10.5.1 now. If you are PC and on cubase10.5 get 10.5.1 likely to help all that. I am still learning this stuff but, I think the Apollo will automatically change to your project settings in Cubase for sample rate and bit depth, Cubase will not allow different sample rate and bit depth settings for your hardware all your hardware sample rate and bit depth have to match for Cubase, you likely already know that but I mention it just in case. Alot of posters here put all their system and version info in their profile so they can get help a little faster.

“1ms latency 128 buffer”
Really?
Have you actually measured it end to end not just what the software tells you?
What is the sample rate?
How many simultaneous live tracks are you recording?

Hippo

I have not tested my sys limits - i am recording 12 simultaneous inputs I have done this at 96kHz 24bit but when down to CD specs for targeting CDs for better mix results so I can hear what that will in the mix

What cubase version - here are my settings



consolle matrix2.jpg

my latency value is not great I guess - but I never have even noticed ANY delay monitoring with headphones, that is because i am monitoring with Apollos console monitor which is ZERO latency, you know it is how UAD instructs in the manual, right?

Just did little test settings in captures below - no issues 12 tracks 150bars.
vstSet.jpg


here are the sys performance meters for the above test
sysPerform.jpg
I do have the Apollos pretty loaded with alot of plugs - so far I am not taxing Cubase

What about your cubase version number, what it it?

Too advanced a set up for me.
I never use such high sampling rates and low buffers and uad as well
If protools and Studio one works fine then what feature is it you need extra from cubase ?

Why use such low buffers when your direct monitoring anyway?

In answer to many comments yes My Apollo settings are pretty much the same as users have suggested, I work at 96kHz so that covers all the platforms and I am using the latest version. I love Cubase as a DAW thats why I am using it instead fo Studio One of PT. I only started using Studio one for laptop sessions but obviously AAF transfers them for Cubase to carry on so I was surprised to see/hear the latency difference. From the mails I am getting most people seem to be working with 256 as thats what works without clicks and pops! which if you think about it with modern machines is kinda screwed up but because most Cubase users are long term users we have all got used to this! But I have to say Presonus have really got their audio engine together. WIth the hotfixs that have been popping up there is obviously an issue, I hope the next one fixes my problem. Getting support seems very difficult when I submit a support request I just get bounced back to the 1st page of support which is sort of frustrating. These days with software its all about the forums. thanks for your advice

So there is no question then really, just a rant about cubase performance at high thread counts and low latency ?

I still say measure you your real world round trip latency (In the box not using the direct monitoring fiddle) using external equipment and the results may surprise you

Never seen in the box software that measures latency accurately.

No there is a question posed at the head. But there seems to be no answer and certainly not a rant! I love CB, been on it since year dot! it makes sense to me more than any other DAW I just know I have a problem here that I can’t get an answer for. My Machine OS is stripped down, no-nonsense in there 9900 I9 RAID SSD good graphics and it flys with the other DAWSI have to use but this clicking popping thing is driving me crazy! to avoid it completely I am having to go to 512 buffer. If I turn multi proc off I can run fast but thats just using a single core!( I think) I have tried every permutation and am getting nowhere, tech supports unresponsive and here I get pictures of people’s settings which should be a piece of cake to set up on my system and I get the pops and clicks that started with 10 and 10.50 and now with the hotfix. I run another DAW and it’s like a grease monkey! so it has to be in Cubase. This has been going on for a while and there are other users having the same problem. its driving me crazy as I am into large projects that I cant overdub in

clicks and pops. First thing I’d check is your DPC latency and see how that looks. Should be OK if your other DAW software is good but you never know.

Are you saying an empty project gives you clicks and pops? Are these clicks and pops in audio recordings, or are they just heard when monitoring?

ASIO guard doesn’t work with Spectrasonic plugins and probably some others so if they’re in your project check out turning it off. It’s possible multi proc is turning off the hyperthreading not the whole cpu cores, you can check easily by looking at your performance meter.

IS your Antelope connected to the Apollo? so your Apollo is the only thing connected ASIO wise? May I ask why you need to have such low latency when you have the Apollo? seems strange as you have a console software for zero latency monitoring with FX. You should be able to run a modest project @128 buffer and 96k though with a new machine.

I always have another (old) audio interface to have on hand in situations like this just to rule out your interface and drivers, do yo have anything to try or borrow?

even AsIO4all and your on board sound @48k is a reasonable test comparison.

M

I record large track numbers at once hence the antelope. I can have an empty project and arm a track and I can hear in the background a one-second thump cycling. the moment I switch Multi core off it goes. I dont get it on the other daws and I get it on both interfaces. I disabled some cores in the BIOS as that was suggested and it made no difference. I am reluctant to mess with the hardware much more as it works fine with the other DAWS so it does point to some issue in CB

Cubase will struggle with large numbers of live recorded tracks and multi cores and non direct in the box monitoring.

ASIO Gaurd is of little use in this configuration

Its just the way it is
Use protools for this kind of tracking
Simple

Hippo

Do we know why this occurs?

The Answer is there between the lines in this thread

https://www.steinberg.net/forums/viewtopic.php?f=283&t=147175

(Hint) Remember that ASIO guard is off for real time recording tracks on all tracks that are armed / record ready / recording

WIndows 10 MMCSS limit is only an issue if you have more than 32 threads, the OP only has an 8 core/16 thread machine, he’s well within the limits.

You’re correct though that ASIO guard is OFF for record armed/monitored tracks so you’re operating just on your project buffers, just like the old days :smiley: Multi cores don’t really help as much with low latency monitoring/recording. However if the other DAW’s mentioned do this fine on the same machine then there’s obviously something going on.

M

Yep I have narrowed the pops and clicks down to the real-time processing. This is where the spikes are certainly metering! teh 9900 is a 10 core chip. SO are you suggesting I limit the threads and how would one do that?

No, the issue is over 16 cores/32 threads. I have a 16 core/32 thread machine and it’s fine though. I don’t try monitor at 1ms however as I have an AXR4 which has zero latency monitoring.


you could turn off Hyperthreading in the BIOS to try. Not sure if it’s still called that :smiley: you’ll have to read your MOBO manual to see.

From my experience and being around pro audio forums, Antelope and UAD don’t have a great reputation for ASIO drivers, do you have another interface you can test with? I know your other DAW works fine but sometimes certain combinations just don’t work well together.


M