Multi-Core Systems on Cubase 11 (over 14 cores)

Is the 14 Core MMCS limit still a thing on windows and Cubase 11?

https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups

Should we be changing Cubase/our system to only run 14 cores?
Should we be disabling Hyperthreading, if Hyperthreading takes us above 14 threads?

Works well with Asio Guard on, not so well with it off.

On my system I have ASIO Guard off and so I disable hyperthreading. How about the number of cores engaged? Should I limit my system to 14 cores (otherwise I have an 18 core chip)?

All I know is I have 32 cores (16 virtual) and with AG off, only about half the cores engage but when AG is on they all work. Hence, I just leave AG on.

How many tracks do you usually have? I’ve got thousands of tracks running, and hundreds of instrument tracks producing audio in the template–I wonder how Cubase is distributing them among cores.

I did a test on my i9 9900 which has 8 real cores so 16 all together. The results are in the computer forum and pasted below. I don’t use AG as it impacts latency

Ok so I used a test track today and the 16 cores are spread out like
cpu core 0 and core 2 50 to 60%
core 5 7 9 11 13 15 about 40%
The rest hovering around 10 to 20%

Not totally even but none wildly different. This is with low buffers and no asio guard on a test track which shows the performance meter hitting peaks in the red. No glitches and track plays out fine. In fact messing with it I still can’t get it to glitch unless I lower buffers below 64

What kind of latency are you referring to? asio guard only affects tracks where latency is irrelevant. That’s the whole point of asio guard…it doesn’t have an noticeable effect on latency.

When you enable it the input and output latency figures change. I haven’t tried on this pc but on my last with a busy project latency would increase if ag was enabled. I’m talking latency playing a vsti. In my case especially SD3 played from a Roland td30 kit.

That doesn’t sound right. Make sure you haven’t exempted your vsti’s from asio guard in the plugin manager. Turn on asio guard. Your cpu usage will go down, all your cores will be used, but your latency when playing a monitored vsti will not change. That’s the whole point of asio guard. :slight_smile:.

Hmm ok I’ll read up on that and try it. I’ve never even looked to see if any were exempted so I haven’t changed anything. Cheers

Ok that seems to work ok. I had effects on the output of my test track which were causing latency and not AG. Looks like I could almost double my test track now! To be honest my projects don’t tend to go over 30 tracks and with or without it works fine. The cores are more even with it enabled though.

All this said, it sure would be nice if Cubase utilized all threads WITHOUT AG on! Moderators?

So, the answer to the OP is: just turn on asio guard and you’ll be fine. There’s rarely any need to turn it off.

Exactly. I’m running a 32 thread Ryzen and it’s all working nicely.

M

I have the same machine Steinberg confirmed and I can also verify the only way to get all the 16 virtual cores to spread even is with ASIO GUARD on…In my own case I use VE Pro and ASIO GUARD on that Plugin has issues unfortunately.

You can turn asio guard off just for Vienna ensemble pro or any plugin which has asio guard issues. In the plugin manager select the plugin and at the bottom you can turn it off. Works 100% here. Not sure what the effect is with many cores as I have only 4…