Multi-key keyboard shortcuts

There was a posting on the forum in June '19 about building ‘complex’ or ‘multi-key’ keyboard shortcuts. The posting was about the importance of the order of the complex string. My question is much simpler:

I wanted to learn a bit more about the mechanics of building complex/multi-key keyboard shortcuts and picked ‘add staff above’ in Edit menu. I can assign the sequence ‘option-S, option-U’ in Preferences and it shows up on the menu. However, when I select an item in a target staff, the keyboard shortcut doesn’t work (the command works fine if I select it directly). I’m clearly missing something really simple. Can someone point me in the right direction? Thanks in advance since I realize this is a very mundane question.

You can only add extra staves to instruments being held by solo players, not section players. Have you selected a section player’s staff?

Yes, trying the key command on a solo player (although thanks for pointing out that you can only add staves for solo players.)

Do you have option-s or option-u mapped to anything else? From memory option-s is the default command for soloing selected tracks in the mixer?


There have been reports that successive meta keys don’t always work. So don’t use Option S, Option U – just use Option S followed by U.

1 Like

Still no luck…with option-S,U or a difference sequence…:frowning:

Did you try deleting this mapping yet?

And which item/s are you selecting in the target staff?

Yes, I’ve deleted it and re-entered it (if that’s what you were asking). As far as selected item in the target staff, I just slected the first note in the measure.

First, test getting any key to work for that command: that will narrow down whether it’s the key combo or the function that’s not working.

OK. I tried several combinations and found an obscure one that does work. So my question now would be why doesn’t option-S, U or option-S, option-U work. The Preferences scan says that neither of these combinations are assigned.

In case you haven’t deleted the „Solo selected instruments“ standard shortcut completely (you wrote you re-entered it), it won’t work.
Dorico cannot know after you pressing opt-S if you want a second shortcut to follow (up to several moments later!).
That means, as soon as the first part of a combinational shortcut is solely in use for another key command, the combinational shortcut won’t work.

1 Like

Ah, that makes perfect sense! There must be a ‘key-command-shortcut dispatcher’ that gets invoked as soon as a key is depressed. If the first key (or modifier-key sequence) in the compound/complex sequence exists, the dispatcher will execute that command (and indeed option-S dutifully solos the selected instrument).
I wasn’t able to find anything in the existing documentation about the ability to define complex keyboard shortcuts, but if that feature is defined, I would suggest that a sentence or two be added explaining that just because the sequence itself is unique and passes the ‘Is this sequence already defined?’ test in Preferences, that doesn’t mean the newly-defined sequence will work. Rather, guidance should be something along the lines of ‘Enter the first modifier+key combination and let it be checked. If it is already defined, you can’t start the complex sequence with that combination.’
Thanks to all for the help. Very much appreciated!