Multichannel AAC file output incorrect.

I have a four-channel montage (as usual), and I can generate 4-channel WAV files as output. In the past I have made AAC files from these using the Nero AAC Encoder, or the Acoustica audio editor, but it occurred to me to check if WaveLab could do it. Lo and behold, I could set it up, and guess what - it generated two channel files…

I really really hope that WaveLab 10 is going to be the version that handles multichannel files at last (just like every other editor, including other Steinberg ones), because because this is not even funny any more. The previous thing I was able to set up and then didn’t work (multi-channel montage output effects in a 4-channel montage) I was told wouldn’t get fixed, so I’d like to believe that what that meant was that a structural fix (handling multi-channel file properly) was finally in the works…


Did you use this option?

Yes, that is set. It works for WAV files; it does not work for AAC files. I just ran it again to confirm I hadn’t done something stupid in a late-night session.

It works her, but you have to select a multi-channel capable AAC format, see:

AAC was multi-channel capable from the very start, several years before AAC-HE and AAC-LC were published, so all AAC versions are multi-channel capable. Also, most sources seem to argue that AAC-HE is optimised for low bit rates, and at high bit rates the processing is compromised compared with AAC-LC, which is the preferred version for quality at higher bit rates - which is presumably why the highest bit rate offered for AAC-HE is only 256, less than I normally use.

So why is WaveLab not allowing multi-channel encoding using AAC-LC (or rather, allowing you to specify it, and then not doing it)?

Back in 2007 an EBU test of multi-channel codecs included both AAC and HE-AAC as separate options, with the AAC (at a higher bit rate) showing a better score.

So why is WaveLab not allowing multi-channel encoding using AAC-LC

It can, if you see a proper config. For example, I just generated with success 2 multi-channel file (4ch and 6 ch) with these settings:

The HE format I mentioned before, is more optimized in final size, for multi channel files (AFAIR).

This is seriously strange. I have the same settings, except that I specified the sample rate to match the input, and slower encoding. When I changed that to 44.1 and fastest encoding, as you have, it produced a 2-channel file at 88.2! (For clarity, that sample rate is as read from the header by MediaInfo.)

Is it possible that WaveLab is picking up a different AAC encoder from somewhere on my machine (which has a lot of software installed), whose parameters aren’t fully compatible?

No, the encoded is embedded inside WaveLab, there can’t be a mistake there. But to be able to encode multi-channel files, there are “bit” limitations. Hence if you use 88k, you probably won’t be able to encode all channels in the same file. IOW, a 4 channels 88.1 file is maybe not supported by the standard.

The file that I produced, were read at the correct pitch in VLC.

Maybe your montages are different? 4 mono tracks or 2 stereo tracks, or mixed? Or different 4 channel routing selections? Seems like that would affect the multichannel wav too if it was an issue, but maybe not.

Now here’s a thing. I created a 4-channel montage using the first 4-channel DVD option. I have four output channels, which play, I can create a 4-channel WAV file. But when I go to look at the montage properties, it says: Mode: Multichannel (DVD-A compatible); channels: stereo. If I change the channels back to the correct setting, the “Apply changes” button doesn’t light up. Is the “stereo” just a display error, or is there some confusion going on here?

It’s a bug. The value to trust is the one when you click at the the bottom right of the screen.

Paul, just to confirm I get exactly the same result as you, using exactly the same multichannel file settings as PG’s screenshot, coming from a 44.1 khz 4 channel DVD montage with 2 stereo tracks. First track routed to Lf Rf, second track routed to Ls Rs. The AAC result file decodes in Wavelab as a stereo 88.2k file, which is a mix of the 4 channels. The result file also appears as 88.2 stereo in Foobar 2000.

Doing the same thing to wav multichannel results in a 44.1 multichannel file that appears as 44.1 4 channel in Foobar.

Thanks for the confirmation; especially useful as I am going away for a week tomorrow morning, and so won’t be able to try anything more for a while. BTW, my montage is four mono files routed to the four outputs.

But using these settings on a 4 channel 44.1 k montage, don’t you get a single file?

Yes, but it’s a 2 channel stereo file, and it’s 88.2 khz. Using your pictured settings, rendering from a 4 channel 44.1 montage.