multiformat export suffix name

Im having a issue with the multiformat export, specifically the suffix added to the file name

in this example i have 3 formats to export, 1 wav and 2 mp3’s, and want to add “128” to the 128k mps and “256” to the 256k mp3
the next dialog tells me what Im going to get, and all looks good
but the result has added the numbers 256 to every file

I can’t reproduce. What is the source? Maybe you are using a naming template by mistake?

the source is suitcase.wav

naming scheme is “unchanged name”

and if there was a naming scheme in place it would show on the “the following files will be created” dialog (my picture #2)

I can reproduce this on Win 10 if the order and suffixes are just like in your multiformat preset, (and the clip name is Suitcase.wav, although I don’t know that matters). Rendering selected clip to :

  1. mp3 suffix 256
  2. wav
  3. mp3 suffix 128

file result is:


also, doing this not from montage, but from an audio file with a different name:

source audio file named temp
render “whole file”
(using the same 3 part multiformat preset as above)
output name: temp-out
option: open files in new file group

the result is:

The files are named correctly, but file #1 (temp-out256.mp3) opens in the same group as the source.

Files #2 and #3 (temp-out.wav and temp-out128.mp3) open in a new group.

I tried multiple times and still can’t reproduce the problem with WaveLab 9.1.
Therefore, there must be an additional option that comes into play. But I can’t figure out which one.
Only thing I could reproduce is the small group issue mentioned by bob.

PG, are you rendering selected clip ? That’s where I’m seeing the difference. The naming problem happens when rendering selected clip, like Adamcal is doing, and I did. I tried with different clip names and still get the naming problem.

But the name problem doesn’t happen when rendering whole file from audio file.

The group problem I see in both cases (clip and audio file).

are you rendering selected clip?

I see, I skipped that info. I can reproduce now.


yeah sorry, I added that afterwards, realizing I had left out that information.

Until it’s fixed, it seems you can get around the problem by moving the wav file to the #1 slot in the multiformat dialog, so that there’s no suffix in the #1 slot. The suffix being in the #1 slot is what seems to cause the naming problem here.

I notice the a similar problem also happens if you use the “Subfolder” going back to my original example it will create a folder called 256, then further subfolder inside that, most likely the same related bug.

good work on the work around bob99