Multiple issues in FL Studio

Hey, I’ve been trying to resolve a couple of issues for quite a long time and at this point I ran out of ideas, so I’ve decided a forum post would beat pulling out more hairs over this.

A little heads up, FL Studio handles GUI-less plugins like the mda stuff by giving them a front-end. Not sure whether it’s generated based on the available parameters or in the plugin’s code. Point is, the mda plugins get a default GUI.

Now, when I compile the example plugins from the VST3 SDK, the mda-vst3 examples don’t have any GUI at all. The window’s resolution would be 0x0 if not for the fact that FL has minimum window sizes to keep settings and buttons accessible. I can still access the parameters through the CC parameter list, but it’s not elegant.
The vstgui-based plugins actually show up with a GUI, however it’s always drawn with lots of additional empty, non-updating space, unless I run the plugin as bridged (which requires more processing power and I’m on low-end hardware), also with vstgui plugins automating a parameter doesn’t change it in the GUI (but that could be missing code in the examples, I can’t tell since I’m a beginner).
On top of that, the plugin browser can NOT find the newer bundle format. It skips over the plugin when it’s in the “.vst3” extension folder, and taking the .vst3 file out of that folder lets the browser find it.
The plugins seem to do fine in the included vst3plugintesthost, but I don’t have any other hosts to test it with and FL Studio is my target host anyway.

I can tell that the GUI issues and browser issues are most likely unrelated considering that I tried VST3SDK 3.6.9, which was a version before the bundle format introduction. Plugins compiled with it and under are seen by the browser just fine but still have the GUI issues listed above. Same goes for versions 3.6.6 (2016), 3.6.7 (2017), 3.6.10 (2018) and the newest builds of 3.6.13 both from Github and from the Steinberg download page.
I can also tell that it’s not my FL Studio install causing the issues, cause trying under FL 12, FL 20.0.1, FL 20.5 on 2 different computers yields same results, doesn’t matter if they’re 32 or 64-bit either.
I also don’t think it’s my compiler or setup, because I gave someone the SDK and the example plugins have the same exact issues.
And yes, released VST3 plugins by manufacturers work perfectly fine for me. Is this a known issue? Should I refer to some version of the SDK (if possible, since Steinberg hides away their older SDK versions, eh.)? I’d like to just go with VST2, but from what I can tell I can’t release VST2 plugins without having signed something by 2018, and it’s not like I can find the SDK easily.



First about the .vst3 bundle folders: There were some changes in the plugin manager in FL 20.5.1 to be able to find plugins inside these folders, but it’s been a while since it was tested so I don’t remember how well it works now. Worth trying if you don’t have that version yet. You could also try the FL 20.6 beta (see our Looptalk forum).

We intend to take another look at this in the future, so we can support them properly if necessary.

About the GUI, I don’t think I’ve ever tested gui-less VST3 plugins as I don’t think there are actually any (released ones) out there. I could be wrong of course.

That said, FL’s generic GUI adds a knob for every parameter published by the plugin, so in theory it should already work.

Ah, that’s one mystery out of the way. In the meantime I checked JUCE out despite being really against it so far and the JUCE GUI works just right. I did notice, however, that if I compile the plugin without an editor it still won’t create the generic GUI for VST3. The parameters do show up in the browser, so FL sees them but refuses to create the surface for some reason. I’ll check it out with the beta whenever I can, but I’d rather preserve compatibility with the folks using older DAWs anyway. I do still wonder what makes VSTGUI mess up though.