Multiple long notes in midi editor

This may be the related or the same as this
I hope so because that one’s being fixed :slight_smile: however, I’m not using a sustain pedal.

I noticed it first when recording DrumsXD through virtual midi, but didn’t worry about it.
But now I have my Fishman Triple Play set up and have started to record midi. But because of the extended notes I can’t edit it in the editor, it becomes just long lines of notes that overlap without any gaps between.
The keys on the left behave correctly, that is they light up and turn off at the correct times but the notes in the editor itself are just a mess.
I’ve tried recording in Beatmaker in case it was somthing to do with the FTP, and it recorded fine.

Any chance of this being looked at for the next update. I really want to start using Cubasis for everything.

Edit: Just tried playing them back with internal sounds (was using SampleTank), it’s almost as if no notes off are being sent the notes just build up and don’t stop.

While waiting I went back through the posts and found this:

This may be the problem. Can the next version please have an option to turn this off? Otherwise I won’t be able to use Cubasis to record midi!

I’ve been experiencing the same thing with certain notes piled on top of each other when recording simple sequences from Little Midi Machine into Cubasis. Tried shortening the gates in LMM, but still had this happening with all notes on one key. No sustain involved at all.

Same here, no sustain pedal at all.

It’s just that the notes have been unnaturally lengthened in the editor for some reason.
The weird thing is the actual piano display on the left actually shows the notes by lighting up - then they go off at the right place but the displayed notes in the editor continue on.

I’m really hoping for a fix on this one, it’s the last thing that’s preventing me from getting started on recording with Cubasis now that the editing has been improved.

Is there any clues on this?
Is it the same as the ‘sustain pedal’ issue even though I wasn’t using a sustain pedal?
Is it possible to have the option to record only notes on and off without any adding to note length in editor for the next update?
Any response appreciated.

Looks like they’re turning a deaf ear to your problem. A lot of synths dont send note off, but instead a note on with 0 volume. I’ve noticed this note extension problem with older sequencers, and now Cubasis. It would be interesting to do a lot of testing to see just what seems to cause it, but not sure I want to be that serious a beta tester for them. If more people complained they might address it, I dont know. Also they need a hold button, not just a sustain button that you have to keep holding down.
Anyway, still a nice daw, overall and I dont want to just concentrate on the negatives, but really they need to fix this so we can sequence and edit effectively. Steinberg, if you read this stuff, please fix.

hey guys,

sorry for the late response.
As we already know, there’s a bug concerning the sustain pedal and midi recording. We’re not aware of the issue your’re describing.
May you send some reproducible steps leading to the problem? I just checked out iRig Midi and it worked all fine.

kind regards

Hi Ludwig, thanks for your response.

I use either DrumsXD (via virtual midi) and a Fishman Triple Play plugged into an Apogee Duet.

The notes seemed to be duplicated on top of each other. There’s a very short one, shorter than 1/192 allowed by Cubasis with grid set to none. This very short note doesn’t have a note off message, when it plays it just doesn’t stop. On top of that there’s a much longer note that just overlaps the next set of double notes. I can’t describe it much better than that.

It seems to happen mostly when notes are played close together in time, but even if played stacatto they overlap making it impossible to edit.

@smeeeth, if you’re still around could you put your experience in as well, the more users that have this prob the more it may be taken seriously.


I’ve experienced this while recording sequencers into Cubasis using virtual midi. Little Midi Machine is one example I recall, with some notes overlapping and extending forever, so you cant edit them easily. There were other situations that caused it also but i can’t remember the setup at the moment.

I just did some more testing in DrumsXD via virtual midi to Cubasis.

Definitely seems it’s related to how close together the notes are played. Occasional crash on cymbal is okay but try and do a drum roll or a couple of close cymbal crashes etc., and the length of the note bar in the editor extends forever :slight_smile:

Is there anyone else experiencing this? If so, please post. I don’t think it’s related to hardware or virtual midi apps but it would be goood to eliminate that. Just try some fast staccato notes on whatever you use and check the note lengths in the editor.

I really want to get this sorted. I’ve got a workaround where I record in Beatmaker and then import into Cubasis which works well, but obviously it would be far better to be able to record the midi in Cubasis directly.


Ludwig, here are a couple of simple setups you might try to reproduce the long stuck notes:

Send midi from Little Midi Machine to a midi track in Cubasis. Send a sequence of the same note for each step at 120bpm. Adjust the gate length of the note to maximum. Record the sequence. Apparently there is a threshold of note length that causes the note not to cut off. Shorter lengths behave normally.

Here is another test:

Send midi from Arpeggiator Pro to a midi track in Cubasis. Set the midi out of Arp Pro so that the gate time is Manual (in the midi out settings under the gear button). Then on the main controls set the gate time to 200%. Record any arpeggio sequence and you should see long overlapping notes in places.

Hope this helps, if I can answer any questions, I will try. Thanks,

Alas, I tested with a Roland controller keyboard through iRig midi today and as Ludwig said there is none of the problem that I’ve described with DrumsXD via virtual midi, and my Fishman going through the Duet, or what smeeeth is getting with his virtual midi programs.
So I guess a fix for this will probably not come soon.
Oh, well, my Beatmaker workaround works and only adds a little extra time/inconvenience.

Hi all,

I did some tests with littlemidi and Drums XD and I can’t reproduce the long notes Issue.

Sustain Notes in cubasis works different as in Cubase, that means cubasis creates note length
like the sustain pedal is hold or the sustain CC data are sending. That’s wrong and this issue is on our list.

Please, can you give us an step by step description with Drums XD include Drums XD settings to reproduce
this issue ?

Too the double / overlay notes after recording :

If you activate for example in NlogPro Devices > “Cubasis” IN:Notes and OUT:Notes simultaneously, you get
double overlay midi notes after recording. Disable in NlogPro Devices > “Cubasis” In: Notes " and all works as expected.


Okay, thanks jan.

I think the best thing would be for me to do a video, upload and paste the link. A picture’s worth a thousand words. I just have to work out how to do it, may take a couple of days. :slight_smile:

Was easier than I thought, not great quality.

Here’s the link

Sorry, it’s in English, wish I could speak German :wink:

Hi RobBr,

Thank’s for the video and your input, we can reproduce the multiple notes here with Drum XD.
We are in contact now with Drum XD to investigate about this issue.


Has this been fixed? The ability to do both MIDI and audio was why I went with Cubasis.

For me this has been fixed, as posted here:
Unfortunately for you there seems to a separate issue with the sustain pedal. As I don’t use one I don’t have that problem. But the problem I had right back from when I started with Cubasis has now been solved.

I really wish SB would do more of these maintenance releases and fix the existing bugs before adding more features. Automation would be nice but I wish all the other issues people are having would be addressed - or even acknowledged would be good. The last I heard from SB on this as you can see from this post is they were able to duplicate the problem and were going to get in touch with the developers of DrumsXD! I wonder what they asked them. :slight_smile:

The IAA which was working well with SampleTank has now got a few probs. The control panel won’t show up in ST and it won’t monitor correctly now either until record is hit.

Among all the negatives of course I have to acknowledge that the interface and routing and simplicity of use of Cubasis is great now that I can record and edit MIDI.

For 2014 I’d like Mutes that stay muted until ‘unmuted’ and an option to have the cursor return to start on stop.

Thanks, Rob, I hadn’t seen that and have not been able to test (I record MIDI at band rehearsals but I don’t have a keyboard at home), so it may be fixed for me too, woohoo!