Multiple of same clef

I’m trying to create a stave that has multiple treble clefs (for students to trace). If I create an identical clef on beat 2, it only shows as a cautionary size. If I scale it up it is a different size/line width/etc

Also, I’ve tried changing the colour of the regular clef but I can’t seem to get it to happen. I want different shades of grey, gradually turning to clear.

Engraving Options > Clefs change scale factor to 1.

Seems I can color mid-system Clefs but not the initial one even if it is explicit.

The initial clef can be hidden by opening the clefs popover and typing invisible.
If you don’t want to see a time signature, select and choose Hide time signature in Properties.
The other clefs can be entered as text (shift-x), using right-click at the text insertion point and choosing Insert Music Text… > Clefs. You will need to scale them up to an appropriate size. With a rastral size 3 (7.0mm), I found that scaling the clef up to 25 points made it the same size as the one at the start of the staff.
You can then change the colour to what ever you like.
Using copy & paste in Write mode, you can also position the clefs wherever you want in Engrave mode.
In the attached project I “removed” the rests, not by using Edit > Remove Rests, but by moving them down below the staff and colouring them white. That way each bar retains its width.

Coloured clefs.dorico (558.6 KB)

Thanks guys, this did the trick!

What a great idea!

For size of following clefs, set scale factor to 1:


So you don’t need to scale each instance.

For your info and @DanielMuzMurray’s, there’s a layout option that hides bar rests whilst retaining normal bar widths.

1 Like

Thanks Lillie, I didn’t think of using that. Is there a way to show a particular bar rest even though this is switched on?

I don’t believe so, no. You would either need to show all bar rests then manually hide the ones you don’t want to see, or show the few bar rests you want to see another way – such as in a text item with collision avoidance switched off, using the Insert Music Symbol dialog.