Multiport MIDI interface for Windows 7

Thanks Filterfreak.

BTW, in the meantime, I’ve already installed .net framework 3.5 sp 1 :ugeek:


hi paolo

im sure you will have as many issues as iv’e had (NoN) ,its just the case of installing manually as the autorun does not run but from then on its pain free !!
best of luck

Hi all,
some good news: I’ve been actually able to install my Emagic amt8 (8 port Midi interface) on Windows 7 32 bit.
This is just the serial (COM) port driver, not the USB one though. Maybe the same method can also work with USB, but since I won’t use it I didn’t even try.

The full history:
main problem was that the old 2.27 WinXP driver doesn’t have a setup file, so you can’t use Win 7 XP compatibility mode (the one you activate right-clicking on the .exe file → Compatibility Tab).
You just have the driver files (.sys, .dll) and an .inf (text) file containing the instructions for the OS to install the driver. I’ve Tried to install the driver using the .inf file (using the option named something like “install legacy hardware”), but that gave me error messages.
So I’ve analyzed the .inf file and compared it to the System registry of a WinXP OS having the amt8 driver installed.

Then, I’ve copied the relevant registry keys from the XP registry, and pasted them to the Win7 registry.

So far it seems to work well, only little problem is I don’t see the Settings Tab on the driver Properties from the Device Manager. Anyway, I can easily change those settings directly in the registry… anyone has a clue why I can’t see the settings in the driver properties?


Registry permissions? Right-click the object in RegEdit and select Permissions … perhaps add the Users group and give it full access?

Tried it: no luck unfortunately. Thank you anyway!

Maybe I didn’t explain myself correctly. Here you are some attachments that explain the situation:

amt8 in Win 7

amt8 in Win XP
amt in Win XP Settings Tab

Impressive Paulo! Thanks for finding this. Is there a chance that this could work in Windows 64 bit, or are the USB drivers unusable there? Thanks.

I’m not an expert at all, but as far as I understand it, 32 bit drivers never work with 64 bit OSs. Sorry.


Don’t feel bad: it’s happily working on my Mac. I’ve got a great DIY GM5-based MIDI interface now on the PC. I was just curious. Thanks for the followup.

:open_mouth: pray tell more! Is it this one?

Yes. There’s been several group buys over at the site, but it looks like the current one (the 3rd) is pretty much closed as there aren’t any more GM5’s available from that source. It comes out pretty cheap for a very good 5x5 interface, but unless you have experience with electronics I don’t recommend it. The only hard part for me was soldering the damn chip in place; it’s so tiny, I ended up gluing it to the PC board so it would stop moving to allow me to solder it. And soldering these chips is a bit challenging: I ended up using the “flood and suck” method :wink:

I’ve built two of these and they work perfectly and are natively recognized on both Mac OS X and Win7-64. But ploytec provides a good driver for windows which runs even better. Obviously I’m using these on W7. For less than 30 euro in parts each it was a good deal.

Thanks Breeze! Looks like a very interesting project.
Have you tried MIDITest (PC) on it yet?

You’re going to make me drag my ass behind the rack unit, aren’t you… :mrgreen:

I’ll let you know.

Just curious, for the guys that are concerned about multi-client drivers - why is this important?

I typically run my gear from Cubase. Are there other midi apps that people use frequently along with Cubase?


Speaking for myself, I run at the same time with Cubase mainly extrernal hardware editors/librarians: Roland Fantom X editor/librarian, Sound Diver (adaptation for the Roland VK8-M), DSI MoPho editor/librarian, etc. I’m sure others would have plenty more examples.


Got it. Come to think of it, I sometimes run an XV editor (for my XV-3080s) at the same time as Cubase. Guess the little Roland um-3g boxes arent the answer then.

I have two midex8s that just work well. Maybe I’ll hold off on the 64 bit upgrade for a while more. UAD card aint there yet either.

I found MIDItest unstable: it crashed on me a few times. But for what it’s worth, here are my port-to-port results with MIDItest. Let me know how it compares to others.

		 MidiTest Results

================ Info ====================================================

Date:		16 Apr 2011
Time:		10:33:51
AppVersion:	4.9.243
OS:		 Professional, Service Pack 1 (Build 7601)
Processor(s):	Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
Speed:		3005 MHz
Number:		4
API:		DirectMusic (direct mode)
Test type:	Advanced
Use timestamp:	yes
Errors:		None

================ Tested Message Types ====================================

		Note off:					yes
		Note on:					yes
		Key aftertouch:					yes
		Controller:					yes
		Program change:					yes
		Channel aftertouch:				yes
		Pitchbend:					yes
		System exclusive:				yes
		MIDI time code quarter frame:			yes
		Song position pointer:				yes
		Song select:					yes
		Tune request:					yes
		MIDI clock:					yes
		MIDI tick:					    no
		Start:						yes
		Continue:					yes
		Stop:						yes
		Active sensing:					yes
		System reset:					yes
		System exclusive mixed with realtime messages:	    no

================ Ports ===================================================

MIDI Output:	GM5 port 4
Description: GM5
DriverDate:	11-26-2009

MIDI Input:	GM5 port 5
Description: GM5
DriverDate:	11-26-2009

================ Results Per Message =====================================

MESSAGES		   Snd		   Rcv		    Snd+Rcv

Message TotalTime:	  734.19 ms	59736.92 ms	60471.10 ms
Message MaximumTime:	    0.25 ms	    3.34 ms	    3.35 ms
Message MinimumTime:	    0.01 ms	    0.56 ms	    0.58 ms
Message AverageTime:	    0.02 ms	    1.91 ms	    1.94 ms
SysexTime:		  179.10 ms	 2796.67 ms	 2975.78 ms
SysexAverage:		    0.00 ms	    0.03 ms	    0.03 ms

    <   1 ms:		   31250	    1280	    1079
  1 -   2 ms:		       0	   17597	   17248
  2 -   3 ms:		       0	   11267	   11787
  3 -   4 ms:		       0	    1106	    1136
  4 -   5 ms:		       0	       0	       0
  5 -  10 ms:		       0	       0	       0
 10 -  20 ms:		       0	       0	       0
 20 -  50 ms:		       0	       0	       0
 50 - 100 ms:		       0	       0	       0
    > 100 ms:		       0	       0	       0

Message count:		   31250	Sysex count:	    1555
Sysex size:		   99990	Sysex passed:	   99990

Message latency:	    1.94 ms	Total time:	 114.776 sec
Message jitter:		    0.54 ms
Message max deviation:	    1.42 ms

================ Results Per Byte ========================================


Byte TotalTime:		25583.25 ms
Byte MaximumTime:	    2.64 ms
Byte MinimumTime:	    0.42 ms
Byte AverageTime:	    0.82 ms

    <   1 ms:		   25577
  1 -   2 ms:		    5107
  2 -   3 ms:		     566
  3 -   4 ms:		       0
  4 -   5 ms:		       0
  5 -  10 ms:		       0
 10 -  20 ms:		       0
 20 -  50 ms:		       0
 50 - 100 ms:		       0
    > 100 ms:		       0

Byte count:		   78916

Byte latency:		    0.82 ms
Byte jitter:		    0.32 ms
Byte max deviation:	    1.82 ms

Interestingly I found this post poking around which shows better results than mine. Maybe it’s because it’s using an older driver and it was done on Vista-32 instead of my W7-64?

Hello Paulo,
I’m also AMT8 owner. I’d like to move to Win7-x86. Can you please share whole steps how you did it? Which registry keys you added to Win7?
Thanks in advance. Andrei.

I strongly suspect you should find the correct registry keys for YOUR system.

Anyway, what I did: I analyzed the winXP registry of an XP installation on a different partition on the same PC of the Win7 32 bit installation, looking for the relevant registry keys for the amt8 (use Regedit to search “emagic”, “unitor”, “amt8”, and when you find one, hit F3 to find all the next recurrences on the the whole registry) and then I applied the same registry Keys in Win 7 (that needed a little tweaking actually: e.g. I remember a particular key that needed some sort of administrator privileges to be edited, but I don’t remember which one; I remember I searched on Google how to edit that particular key, and found the solution).

For the same purpose, I also analyzed the UNI2k227.inf file: the old 2.27 WinXP driver doesn’t have a setup file, you just have the driver files (.sys, .dll) and an .inf (text) file containing the instructions for the OS to install the driver.
So, I’ve analyzed the .inf file and compared it to the Win XP System registry.

Then, I copied the driver files to the Win7 system32\drivers folder. The driver files are UNIS2K.dll and UNIS2K.sys (valid only for the serial connection, that I use; for USB connection, the files are different, but I don’t remember their names).

A complicated job indeed, if you are unaware of the risks implied in tweaking the Windows registry, you’d better give it up…or at least do a complete backup of your system before you start…

Sorry I can’t be more helpful.


OK, here you are something more detailed.

One BIG WARNING though: the registry keys contained in the files are those correct for MY PC and MY configuration, you must adapt them to yours. Backup EVERYTHING before, if you’re not sure what you’re doing.

Emagic amt8 (serial) Driver install (custom)

In Windows 7 32 bit:

  • copy UNIS2K.dll in c:\Windows\System32;
  • copy UNIS2K.sys in c:\Windows\System32\drivers;
  • start Regedit;
  • go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96C-E325-11CE-BFC1-08002BE10318};
  • note down the last subkey number of that key;
  • open amt8s_1.reg (contained in the attached zip file) with Notepad;
  • “Find and replace” every instance of “\0XYZ” with last subkey number + 1;
    (for example, if last subkey number is 0008, “Find and replace” “\0XYZ” with “\0009”);
  • exit and save amt8s_1.reg;
  • do the same with amt8s_2.reg (also contained in the attached zip file);
  • double click on amt8s_1.reg;
  • start Regedit;
  • go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root;
  • right click on Root;
    - NOTE: my Windows 7 version is localized in Italian; I don’t know the exact English equivalent for the following steps, if you use the English Windows 7 localization;
  • Autorizzazioni;
  • Avanzate;
  • Proprietario → Modifica proprietario in:
  • click on Paolo (Paolo-PC\Paolo); this is my username on Windows, you must click on your username;
  • OK;
  • Utenti e gruppi → click on DIRITTI PROPRIETARIO;
  • enable Consenti → Controllo completo;
  • OK;
  • double click on amt8s_2.reg;
  • restore previous Proprietario;
  • reboot;
  • DONE!

One last thing: I absolutely don’t guarantee this will work for you, do at your own risk! Anyway, please let me know should it work!

Paolo (2.31 KB)