Multiport tangle

I’ve been trying to set up my VEPro orchestral template with multiple midi ports, to cut down on the number of instances as recommended by VSL.

So far, violins are fine on one instance, but the lower strings – all on the second instance – it sounds like the XP map for the violas, assigned to port 1, is addressing port 2 & 3 as well.

Context: I use Dimension strings, and have set up relative channels for switching between open/mute/sul tasto/sul pont., which works fine.

Here are a couple of rough clips of what I’m getting:

Note that with only violins selected, I’m still getting sound from the lower strings.

The EmVoice VST seems to operate in a similar manner. The vocal synth plays regardless, of whichever other part or parts have been selected, and when exporting audio as separate instruments, EmVoice imprints itself on every part. Although EmVoice has its own channel in the Dorico Mixer and its fader does control its playback volume, it seems to circumvent the standard Dorico output channel(s) in other ways.

Clearly EmVoice uses an unusual VST/remote structure, so I do not anticipate Dorico is set up to handle (or take responsibility for) this , but for those using EmVoice, it is worth knowing, and if, while exploring the situation @Marcabru has described above, the Development Team sees that a solution to the EmVoice situation is similar, I would not be sorry to hear of it.


Looking at the mixer under Play, I noticed that I wasn’t seeing faders for 'cellos & basses, so I looked into it. Normally I never use this section – making those adjustments in VEPro – so I’m not familiar with it.

In this pic, the Endpoint setup for violins specifies 2 audio outputs in the mixer; for the lower strings I left that option unchecked.

Notice that the two outputs for the Violins are the consecutive channels, not the first two Assigned Instruments. Lower strings is set up with three ports, for violas, cellos & basses respectively, so 48 channels in total. I guess the 32 visible outs relates to the Dorico audio engine’s capacities.

More again:

Difference between upper and lower is that upper uses a single XP map, whereas lower has separate ones for viola, cello & bass.

I noticed that when I click-select the individual notes, as per the score in the media clips, the violins all sound individually. The violas, though: when I click on the first, and the second, I get the three-note chord characteristic of a wrong xp map assignment. When I click on the third, I only get a two-note chord (viola & cello) – because (presumably) the basses only use the first eight channels. [edit: when I click on the cellos & basses, I get no sound at all.]

Found the problem: failed to change the port assignations in VEPro. Thought it would be an error on my part.