MusGlyphs: Bravura for writing in time signatures and other glyphs

Really wonderful! I wish I had it when writing my essays at the university! :slight_smile:


Totally agreed and FWIW I’m, extremely grateful to Florian for Metrico - a really useful and important addition to Dorico over the past few years. But now that MusGlyphs has arrived, it’s moved things on and I personally would prefer to do this kind of thing with one font as opposed to mixing things up with two.

Well, if Florian doesn’t object, I’m happy to add the needed modulations to MusGlyphs. Maybe someone could list the most common ones?

I doubt very much that I’ll be able to create all iterations… and in due time, this native functionality will probably come to Dorico. But in the meantime, I can add a few as needed.



Congratulations on this fine realization. I purchased and installed your font. Inserting musical symbols into text has always been a problem for the changes to line spacing. I have always used Dominique Montel’s Rousseau font, which exhibits this problem. From the few tests I have run with yours, it appears that one has to experiment until the font size of the group of symbols is small enough to prevent line spacing from being modified.

Furthermore, unless I am wrong, one needs to select each group of symbols, set a font and size, and set all the correct kerning parameters under Font | Advanced for everything to appear as expected. This set of steps is obviously a candidate for a macro.

What is the procedure to download what appear to be frequent updates? Download again for free?

Finally, I would like to point out that the cheat sheet is version 1.45 in the downloaded package, and 1.46 on a Dropbox link in your post of 7 April that was valid a couple of hours ago but has now ceased to be. Is there a permalink to the latest version?

Hi, and thanks. Hmm… MusGlyphs is intended to correct this exact problem, so the user doesn’t have to resize and align. I find any of the typical fonts I use work nicely with MusGlyphs by default. But you’re right that line spacing can be an issue. Some of the glyphs are quite tall, so the values for WinAscent and WinDescent (basically, how “tall” the font metrics are) are set to large values. I am looking into ways to adjust this automatically, but as you can see on the MusGlyphs product page, it should be possible to make the font play nicely with text.

Also, at least on Word I know it’s easy to assign a key command to a particular font, so you can easily switch back and forth.

Regarding kerning: at least in Word, I would recommend simply turning it on and leaving it.

Updates: all “official” updates will be pushed out through Notation Central, and you’ll get an email with a link. That’s the best way, rather than relying on the Dropbox link, which may disappear at any time, or may link to a beta version that has some issues! The official version is still 1.45. The beta, 1.46, has a few changes that may throw you off a bit, which will be documented in the version history (they’re quite minor).

Oh and by the way, 1.46 will include support for metric modulation, which I think is nearly finished.

Here’s some nonsense, achieved by typing <7e=s5>…




Thanks for helping me realize that there is a button to set kerning as a default (lower left corner).

Brilliant, Dan! Purchased and installed, and already used a number of times.

In early music I need to refer to time signature 3 without a denominator, for example when explaining this in a footnote. Might this be possible?

Marc-André, I’d missed the default kerning tip in Word, so thanks for mentioning.

Hmm, not at the moment. Is this a common thing? I would need to add it as a custom ligature.

3 by itself is fairly common in my experience covering various triple time situations, where C and cut C cover duple time. (C3 as a combination is not common, I’d say.) It’s the 3 that would help me. Dorico allows a Time Sig of 3 by entering 3/2 or 3/1 and turning off the denominator in properties - but as I say, it’s being able to refer to 3 in a footnote that would be useful. Thank you for looking at it!

It is really common in early music. See Heinrich Schütz, SWV 494, at IMSLP (Bärenreiter 1950), right on the first music page.

It appears that the ligature settings (in MS Word) are a property of a text block (like bold, italic etc.) and cannot be activated globally/permanently on a per-font basis. Is this correct?

Right now, I seem to have to reactivate ligatures for each new document, and every time I change paragraph formats. Also, if I activate ligatures for MusGlyphs and change to a different font, then ligatures are activated for that font, as well. Is this just the way it is, or am I overlooking something?

I suppose I could change the “Standard” paragraph format to use ligatures and kerning, but I’m not sure about possible side effects…

Yes, I believe that’s correct. Of course you could always create a template, .dotx.

1 Like

Ok, I’ll add that as a ligature. Thanks.

Did “alteration stacking” make it into production? I’m not able to put b9 and b5 on top of each other, so maybe that feature wasn’t workable? (Too many combinations?)

Also, out of interest: Which software are you using to create fonts?

Generally: Awesome work, thank you very much. It’s no wonder that some people on this forum think that you’re a Steinberg employee. :smiley:

Thanks. Yes, the stacked alterations were just too daunting at present, since there are something like 24 combinations. I need to learn how to use composite glyphs to create them…

I’m using Font Creator. I like it a lot. I find FontForge too difficult, but I didn’t want to spend $600 for one of the high-end ones. This program works great.

Only 24?


Well, I’m thinking specifically of stacked alterations within parentheses. 17 of the ones you posted above are already achievable, or basically so.

Just a quick note to say that MusGlyphs 2.0 is now available for free from Notation Central, and includes comprehensive metric modulations and a bunch of other new things.


Found the problem with the non-working hyphen ligatures—it’s because I was using Compatibility Mode on Word. As you write in the notes to v2.0, we need to use .docx. Works like a charm now. Well done again and thanks!

1 Like