Musical Mode glitch?

For someone who doesn’t work with loops on a regular basis, I find the following behavior quite puzzling and wouldn’t mind if someone more experienced with tempo synced audio loops would let me know what went wrong here.

I would assume in the following scenario that the audio file did not change size when Musical Mode is activated since the tempo set matches the tempo of the audio loop.

Below you can see Media Bay reporting that the file is 2 bars long and its tempo is 84.64 bpm, same as the project tempo.

Musical mode

And here’s what the same file looks like in the Audio Pool.

Why does the length of the clip change when I toggle Musical Mode even though the project tempo and audio file tempo is the same?
What can I do to fix this so that in the future, Musical Mode keeps the length of the clip to 2 bars?

Hi, I notice an issue (?) in the file and its tags: I see the bpm at 84.64 and the length at 5:20 secs, while I see in the pool the correct 5.671 secs. The “original” 5.20 secs, is around 1.83 bars. So I suspect that upon changing to musical mode, we get an expansion of around 9% of the length. In 16ths this would be somewhere near 2.9, thus adding 2 16ths and the remainder in frames. Though I didn’t verify the calculation by watching the gif you posted. Not sure if this would be of help…

Thanks @m.c ! As always, you have a sharp eye. I didn’t spot that discrepancy.

I still don’t understand why this is or how to fix it. I have a folder with 30+ audio loops that all display this same issue.
On top of this, the Event Snap Point of all of them is off. I know how to move the snap point but I don’t understand why I would have to. As in, why does the Event Snap Point not default to the very start of the clip?

I could really need some insight in what is going on here, what I might have done wrong and how to rectify it.

Why does the length of the audio file differ between MediaBay and the Audio Pool?

From what I see, the pool has the correct duration. Mind sharing with me this specific file just to check how it’s imported in mediaBay?

Thank you!

OK, scanned it, and I get the same duration in mediaBay as the one you get.
Then I imported it to a blank project. At first, I saw the same thing happening here, the length was changing based on musical mode on/off. Seemed like it was calculating based on a ration of 4.168:4.05. Then, I changed my transport primary time format to seconds, and after that, even when I changed back to bars+beats, things got to work as expected. Not sure what’s going on either, a more experienced user might help.

@m.c Thank you for trying.
I tried following what you did but I can’t seem to reach same result.

Here’s what I did.

  • Start a new, Blank project
  • From Media Bay, I dragged the loop (Shaker Loop 28.wav) to the Project Window and a new Audio Track with the audio file was created.
  • As the Event Snap Point was not set to the very start of the Audio Clip (this is another annoyance), I double-clicked the event to open it in the Sample Editor and dragged the Event Snap Point to the very beginning of the clip and closed the Sample Editor.
  • With the Snap Point now set to the start of the clip, I corrected its position in the Project Window to have it start exactly at bar 3.
  • At this point, the Info Bar tells me the length of the clip is “1. 3. 3. 98” (It should be “”).
  • I changed the Ruler setting from “Bars+Beats” to “Seconds”
  • I changed the Ruler setting from “Seconds” back to “Bars+Beats”

I see no difference.

Surely there must be someone in here that understands how this is supposed to work and why it isn’t in my case for 30+ audio loops.

I haven’t noticed this. Maybe I should test it on CB12 as well…

Yes, I wonder too why there’s no explanation coming from guys using loops…

Thanks m.c.
I just wrote Steinberg Support an email. If I ever get a response, I’ll update this thread.

I am still in communication with Steinberg/Yamaha support but I thought I’ll update this thread with the information I have provided the support team.
It’s basically a more detailed step-by-step with screenshots along the way.

If anyone reads this and the behavior looks familiar I would love to hear about it.
If anyone has an interest to try this on their own rig, I am willing to share the audio file used below—PM me.

Click to open :point_down:

The step-by-step
  1. From a complete power off state, I booted up my PC running Windows 10 Pro (see complete Windows specifications towards the end of this email)

  2. I have 3 version of Cubase installed on this machine, Cubase Pro 10.5, 11 and 12. Since I had previously already moved the preferences folders for version 10.5 and 11, only the preferences folder “Cubase 12_64” was present. I moved this folder to my desktop.

  3. I rebooted Windows.

  4. I started Cubase 12 Pro

  5. From the Steinberg Hub, I selected “Create Empty…” and picked a newly created folder for the project.

  6. I opened a Windows File Explorer and navigated to where I stored the shaker loop audio files in question.

  7. From the Windows File Explorer I dragged and dropped the file “Shaker Loop 28.wav” onto the Project Window in Cubase onto bar 3 (see screenshot)

  8. In the Import Options dialog, I only clicked the button “OK” (see screenshot)

  9. Here is what I was presented with after the import (see screenshot)

  10. Here I see two issues. Issue #1 is that the audio file did not snap to Bar 3 as I would have expected, but rather “” as seen in the screenshot above. Issue #2 is that the length of the audio file appeared to be “” when I expected it to be “”.

  11. I opened the Audio Pool and saw the following. Note the tempo and time signature. (see screenshot)

  12. I Quit Cubase without saving the project.

  13. I started Cubase 12 Pro again and from the Steinberg Hub I once again selected “Create Empty…”, created a new folder and selected that folder for this project.

  14. I opened Media Bay and in the left hand side file browser I navigated to where I have the shaker loops stored.

  15. I ticked the box in the Media Bay to add this single folder to Media Bay and the content of this folder immediately was shown in the “Results” pane of Media Bay.

  16. After I reorganized the columns of the “Results” pane, this is what I saw (see screenshot)

  17. Here, I note two things. The tempo shown in Media Bay matches the tempo shown in the Audio Pool from my first, above attempt at importing the file “Shaker Loop 28.wav”. Secondly this file shows “2.0” in the column “Bars & Beats”.

  18. I drag and drop, from the open Media Bay, the same file, “Shaker Loop 28.wav” onto the empty Project Window. This time to bar 5. (see screenshot)

  19. Here is the results after I only press “OK” in the Import Options dialog, just as last time (see screenshot)

  20. Here I noticed that the file/clip is not set to Musical Mode as it was automatically in my first attempt when dragging the file from Windows File Explorer.

  21. On the Info Line, I click Musical Mode and this is the result. (see screenshot)

  22. Here I notice a two things. #1 the start of the audio file did not snap to bar 5 as I would have expected (same as in my first attempt). #2 the length of the audio file, as shown in the Info Line, is “” where I would have expected the length to be “” as stated in the “Bars & Beats” column in Media Bay. (see point 16 above)

  23. In the Info Line, I removed Musical Mode from the Audio Clip.

  24. I changed the project tempo from 120.0 BPM to 115.15 BPM to match the tempo of the file as reported by Media Bay and Audio Pool. This is what I have at this point. Note that the length in the Info Line now correctly reads “”. (see screenshot)

  25. In the Info Line, I adjusted the Start of the Audio Event from “4.4 2.49” to “”. At this point, everything lines up correctly. (see screenshot)

  26. I re-enabled Musical Mode for the Audio Event and noticed that the Length of the event changed from “” to “”. Note that this Length shown in the Info Bar differs from my first attempt (point 9) as well as my second attempt (point 21) where the length was reported as “”.

  27. On the Transport Panel, I changed the Primary Time format from “Bars+Beats” to “Seconds” and noticed that the Length shown in the Info Line reads “0:00:04.145”. (see screenshot)

  28. I open the Audio Pool and notice that the length of the audio file in the column “Info” reads “4.168 s” which differs from what the Info Line shows in the above point 27 screenshot. (see screenshot of audio pool)

Final words
There seems to be several inconsistencies going on here and I can’t make heads or tails of it.
Why does the Length of this audio file show different values in Audio Pool vs Info Line?
Why does this audio file not conform to the “2.0 Bars & Beats” as shown in Media Bay?
Why does this audio file not snap to start of a bar when dragged from either Media Bay or Windows File Explorer?

Could these be some kind of rounding problems inside the hood? Is this specific to certain audio file or just randomly everything. I’m not that good in math, so this is just an idea

My guess is that it is not a rounding error. If it was, I believe it would be a much more prevalent issue affecting a lot more people.
So far I have found it affecting some 30+ audio files, all edited to be used as loops. My experience with using audio loops is abysmal which makes this particular issue a bit harder for me to diagnose.