Mute Then Un-Mute Causes VSTi To Play Out Of Time

Mute Then Un-Mute Causes VSTi To Play Out Of Time

I seem to be having a problem with Cubase that has followed me between two versions, I have 7.5 installed and now also just installed 9.5, both versions do the same thing. I have also tried 3 different sound cards with the same results.

Have made two videos which show the problem, thought it would be easier to see the problem as well as me explain in text. :slight_smile:

https://drive.google.com/open?id=1aTN2SI1WIBi1gDn98L3BnP0cP3Pw7pws

https://drive.google.com/open?id=1fshBfvJiLbBDkmg0Npm-Y2uDpA_WeCoD

As you can see in the videos, I have Cubase setup on a global 32-beat loop, I have Nexus 2 playing drums and bass on two separate instruments, both with a single key press over a 16-beat midi.

Now if I mute or un-mute on either the bass or the drums mid-way through the 16-beat midi, if I don’t un-mute exactly on the beginning of a beat, you can hear it goes out of time.

Same thing happens if use the mix tab on Nexus to turn on or off one of the sounds in the mix, it goes out of time.

Confirmed Omnisphere is doing the same thing, so pretty sure the issue lies with Cubase somewhere. If anyone has any idea’s, or if I am doing something stupid please let me know lol.

Thanks. :slight_smile:

Hi and welcome,

As far as I understand your project… You send a MIDI Note to Nexus. This triggers some arpeggiator in Nexus. It triggers the arpeggiator exactly at the moment, when the MIDI Note comes. So if the MIDI Note comes out of sync (not exactly in the grid), the whole arpeggio is shifted (delays). Am I right?

The same is with Un-Mut (in your case Solo/Un-Solo). When you Un-Mute out of the grid, the MIDI Note is send from Cubase out of the sync (because it’s send at the moment, when you Un-Mute). This is the reason, why is your Nexus arpeggiator shifted then.

The solution could be (if I’m not wrong) to disable Chase MIDI Notes:
Preferences > MIDI > Chase Events > disable Note.

Once you do this, you should hear the Nexus loop until the moment, when new MIDI Note is sent from Cubase, after Un-Mute. So once you Un-Mute you wouldn’t hear anything, until a new MIDI Note comes in.

Thank you for the reply Martin. :slight_smile:

Yes I think your understanding of what is happening is correct. Even tho the drums and bass aren’t arps as such I think, you might be right there. I need to take a closer look tomorrow and will reply.

I take it there is no way to have the mute buttons snap to the grid at least? This would at the least stop nexus from coming back in way out of time.

Or, is there anyway to keep the midi running to nexus, but route it’s actual audio out to an audio track and I could mute and un-mute the audio track without getting this problem?

I am on my ipad now, so I will reply properly tomorrow, explain why I need to use the mute and explain why your solution at the bottom while very much appreciated may not work for my needs.

Thanks again for the reply hey. :wink:

Hi,

No, there is no way, how to sync Mute/Un-Mute with the Grid.

What could help is to Mute/Un-Mute in the MixConsole. Then you don’t mute the source MIDI data (as you do if you Mute in the Project window), but you Mute the Audio Return Channel. So this is exactly what you are asking for. MIDI data is not Muted, but the Audio is Muted. Let me know please, I wonder about the result.

Hey Martin,

Good news, I have a working solution after having a quick chat with Steinberg support over here in AU this morning after checking your method which unfortunately didn’t work.

I opened my mix console and noticed the mute / un-mute when clicked on there would also mute / un-mute in the project on the instrument track, they seemed tied together.

Get this though, really strange but so happy it works.

This guy told me to create a midi track, then drag and drop the midi that was on the Nexus instrument track onto the new midi track, then assign that midi track to that Nexus instrument track.

Now when I hit mute on the mix console for the Nexus instrument track, it only mutes the audio. This also stopped there being a tie between the mute button on the mix console and the instrument track itself on the project screen. So when I hit mute on the mix console now, it does not change the mute on the instrument track in the project.

What made my day was I am using the Novation Launch Control for mute / un-mute. For whatever reason this now still works perfectly and mutes the mix console and not the instrument track in the project.

It all worked out perfectly!!

Thanks very much for the reply and input. :wink:

Dave