Muting an Instrument track Mutes the Midi Events which cause sync issues

Hi music Lovers

We’re all familiar with instruments that have a sequencer and arpeggiator and I’m one of those guys that mute/unmute tracks alot while writing to make my decisions.

When I do this while the song is playing inside Cubase on an instrument track I face sync issues.

It’s a single note, say F for 8 bars triggering the sequence in the instrument

If I mute and than I unmute the instrument track the pattern goes out of sync. That’s because Cubase mutes both the output of the instrument and the data being sent to it.

Do you have any workaround to this? Other than sending the output of the instrument track to an audio channel and mute/unmute the latter instead? It works but it defeats the purpose of owning a 600 Euros DAW in my oppinion :laughing: it’s a waste of Cubase!

I hope no one else is experiencing this other than me because it’s really annoying.

Trigger your NOTE every quarter not and your syn issue may just go away.

Also, your buffer is probably too high there for the audio driver.

Option:
Glue all the midi data together then you could use the MUTE tool and just mute the midi data

Your problem here is that Cubase is quite smart in that it will try to resume a VST instrument at the correct play-state when you unmute it - this is called MIDI chase.

i.e. What this does, is if you held a chord for 4 bars, muted it on bar 1 and unmuted on bar 2 - it would still play the chord from Bar 1, at the point of unmuting in Bar 2 by generating the MIDI ON notes for you.

So, what’s happening in your case is at the point of unmuting you are causing Cubase’s MIDI chase to fire the arp early as a result of the MIDI On data it has held in it’s buffer.

Hope that makes some sense! :slight_smile:

To disable this behaviour simply disable the Note tick box in Preferences > MIDI > Chase Events. This will stop notes from being triggered until the playhead passes over the next MIDI Note On messages (When unmuted), and cubase won’t try and be smart about it. This is how most other DAW’s behave, and will correct your issue.

The other method to get round this is to mute the actual MIDI events, and not the track itself… i.e. you can either right click on the track and ‘select all’ then press Shift+M to mute the events, and Shift+U to unmute. Or, you can manually select the events you want to mute/unmute, again using Shift+M/Shift+U. Muting in this way also doesn’t trigger MIDI note chase even if it’s enabled.

Also, there’s an option on the top for setting the mute status of selected events using your mouse if you don’t like keyboard shortcuts.

One other thing, of course is that you could just control it via the tracks volume fader.