My Dongle is not working anymore

I bought my cubase on 2020 august, version 10.5.
Never had any problems with my dongle before.
Today when I tried to open my Cubase (still working on 10.5) with my dongle connected, it said: “No valid license found”.
I went into the eLisenser control- select elicenser - and tried to update it but it’s not even recognizing my dongle. - Just saying "currently there is no eLicenser connected to your computer
(though the pc shows it’s connected, and there’s a red light on it).
can you please help me?

Welcome to the forum.

Have you tried to connect the USB eLicenser to a different port in your computer?

Yes i have, also tried to connect it to a different pc.

OK that sounds like a defective USB stick. You probably need a replacement and should read this

Thank you, I read it.
So I need to buy a new USB and reload my license on it.
If I would upgrade to Cubase 12, can I do it without buying a new dongle?
Or would I still need to use my a dongle for the transition?

For the upgrade you need to have the eLicenser connected. The process marks the previous license as upgraded on the dongle, so it needs to be there.