My e-licencer doesn't list my codes

I can never enter an activation code to the e-licencer control center. I did everything as it told me to do. When I enter the activation code in -elicencer, it shows this error despite I downloaded the latest version of elicencer again and again. Besides, my activation code is in this form: 00000-00000-00000 as 5 by 5. But in e licencer it shows it as 0000-0000- as 4 by 4. I didn’t make it. Please, help. I’m from istanbul.

Start with installing the latest version. Download from here:

Thanks but it doesn’t work. I downloaded it from the same link. It opens a screen like this and it doesn’t fit my activation code. When I enter the code it says the same thing again such as “your version is older”. I got it from the new link? How can I solve it? Installıng cubase was terribly difficult and it is not user friendly. :confused:

Use the Download assistant to enter your code.

1 Like

Thanks but I did it, download assistant perfectly worked and installed everything coming with the cubase 12 pro package. The software is working well. But I can’t see my software in e -licencer screen unfortunately . It’s empty and I tried many times to download it again. Same response. “It is old”. I donwloaded it from the same link though. :confused:

Cubase 12 and most other products currently being sold by Steinberg don’t use the eLicenser at all anymore.

Thanks. Everybody talked about the e-licencer and nobody told me I don’t need it for 12. Thank you very much. :slight_smile: