My eLicenser Control Center can't find my dongle

My windows can find eLicenser. but, Windows can’t find eLicenser Driver.
And I downloaded eLicenser Control center. and eLicenser Control center can’t find my usb-elicenser.
How can I solve the problem?


Do you have the very latest eLCC installed? Make sure no firewall or antivirus blocks the communication.

You can also try to plug your USB-eLicenser to other USB port. Btw, do you have the latest short USB-eLicenser?

You can also try to install eLCC Helper.

I have the same problem! Windows can’t find the driver for my usb elicenser. I’ve tried every single suggested solution in the FAQs SEVERAL times. I took the dongle out and inserted it in my second computer, which runs Windows Home rather than Windows Pro, and it installs the driver without any problems; and when I run the eLCC it finds the usb elicenser and the license, again with no problem whatsoever. Yet when I reinsert the dongle back into ANY usb port of my studio computer (Windows Pro), the Device Manager finds it but tells me it’s unusable, and it can’t find a driver for it anywhere. I’ve run through this entire procedure twice, to no avail!

The only solution I can think of now is to erase my entire C-drive and do a clean reinstall of the Windows OS, but then it will take a week for me to reinstall all my programs an sound libraries, and I don’t even know if that will solve the problem. It’s a real nightmare! Help!!!

Hi and welcome,

Have you tried to install eLCC (and the driver with it) as administrator, please?

Hi Martin. Thanks for responding. Yes, I have. I finally figured out it was Windows that couldn’t find the dongle driver. Nothing I did worked, so I opened a support ticket with Steinberg and went deeply into the Windows knowledge base, where I found out it was due to a glitch in the Windows 10 upgrade process. I followed all fixes suggested to no avail. Ultimately, I had to wipe my C drive and reinstall Windows and Cubase. That, of course, solved the problem, though it seems to me the real problem is having to use the damn dongle in the first place! Thanks again.