My licenses are stuck on a lost soft elicenser, please help

So last week at some point my soft elicenser disappeared, I’m thinking this was something to do with a windows update but I don’t know. I have purchased the license dongle and figured I could just move my licenses on there but in mysteinberg account the licenses are still on my old soft elicenser, god knows where that’s gone to, and I can’t reactivate as it will only let me do that to another soft elicenser. I’ve tried redownloading the elicenser control centre to get a new soft elicenser but that hasn’t worked, I went on to try that as admin and the installation helper regularly and as admin with no success.
So I’m stuck in this strange position of having the licenses, and a usb elicenser but I’m unable to combine them in a way my computer will register as me having permission to run the software. I’ve even deleted my account with steinberg and set up another one, registered my hardware and my new usb elicenser again and it still brings up my licenses on my old soft elicenser which has vanished.
It was welcome news that there will be a new access system soon but if anyone knows a way for me to get my DAW up and running in the meantime, advice would be greatly appreciated. Thanks

Have you tried REACTIVATING the licenses on a new soft eLicenser?

I have. No matter what I do it fails to create a new soft elicense. Elcc will install and open on it’s own but have no new soft elicenser, when I use the helper it just fails. Thanks for your response

You can do a trial of the software in the meantime…

1 Like

I’ve been on 10.5 so I’m worried I may make all kinds of problems with my projects by switching to a trial of 11 and then back again (which seems to be the only option?). Although I’m grateful for the suggestion.
Just tried calling the support team as I have tried all other ways of contacting them. I, like most people these days, don’t have a landline so I had to top up my phone especially for the call, to Hamburg, from the UK. Bringing the total spent on trying to fix this issue to 37 pounds. All I got was a recorded message giving me a link to this website…
I see that steinburg support occasionally respond on these forums, does anybody know my chances of a response ?
Getting frustrated to say the least. Company is a bit of a joke man, seriously considering getting a new DAW. Any recommendations for ones that you can access easily after buying them are appreciated.

Give this a try. ELicenser Control Center Troubleshooting Guide | Sweetwater

Specifically the Run eLC Helper application (Soft-eLicensers only) section.

Thanks. If you re-read my posts you’ll see that I’ve tried all of these things and more

You can run 10.5 using the C11 trial license.

A post was split to a new topic: Software licenser shows in red deactivation