My presets and default presets are gone

Hi,

I haven’t used Cubase for about 3 months or so and launched it yesterday for a new project. And for some reason my presets are all gone and so are the default ones. I have C6 64 and C6 32 installed side by side and all my presets are still there in C6 32. How can I solve this without reinstalling C6 64 or trashing prefs?

It’s easier to see what I’m talking about in video: http://youtu.be/x-eoooQh9ZM
Thanks

I browsed to directories for the 32 and 64bits version of Cubase
C:\Users\Name\AppData\Roaming\Steinberg\Cubase 6\Presets
C:\Users\Name\AppData\Roaming\Steinberg\Cubase 6_64\Presets

And many folders are missing! How come? Can I safely copy the missing folders from the 32 preset directory to the 64 one without corrupting anything?

http://img811.imageshack.us/img811/2738/38710676.jpg

EDIT: Although I just created a track preset to test things out, I can’t find any *.trackpreset file in \Documents and Settings<user name>\Application Data\Steinberg\Track Presets as stated in the following link:
https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/cubase-and-nuendo-program-preferences-files-in-detail/

I tried to use Reverence and also no preset are showing.

Same thing with each included plugin.

For retrieving the presets of a C6 64 bits installation, I would do the following :

  1. Carefully backup all the content of the C:\Users<username>\AppData\Roaming\Steinberg\Cubase 6_64\Presets folder,
  2. Delete all its content and copy in it all the content of the C:\Program Files\Steinberg\Cubase 6\Presets one,
  3. Add back from your backup eventual custom made presets in it at their relevent places,
  4. Launch Cubase and use Mediabay to rescan all the involved folders, especially the C:\Users<username>…\Presets one and its subfolders.

Thanks, I just did that. Unfortunately the presets are stil not showing.

Hmmm… Sure of Mediabay rescan ? If so, I’m afraid that you are for a C6 repair/reinstallation…

FWIW, here is my C:\Program Files\Steinberg\Cubase 6\Presets contents (see the attachment). Do you have more or less the same thing ?
ProgramFiles_PresetsFolder.png

Ok, maybe I’m doing something wrong with the Mediabay. Your post made me rescan the Factory Content folder in Mediabay.

http://imageshack.us/a/img818/6857/58296437.png

Now the default program presets are showing fine:
http://imageshack.us/a/img541/9154/76536274.png
http://imageshack.us/a/img838/2304/83225423.png

But when I close Cubase, restart it and create a new project with a Reverence or GEQ-10 instance, the presets are still not showing. I have to rescan Factory Content folder in Mediabay to make them reappear. I don’t get it.

Well, maybe something more radical… Get rid of the following preferences files (C:\Users<username>\AppData\Roaming\Steinberg\Cubase 6_64):

mediabay3.db
MediaDefaults.xml
MediaFactoryDefaults.xml
ContentManager.xml

Then relaunch Cubase and make a complete rescan of your system with Mediabay, carefully choosing all the rinvolved folders. Will take a while but, at least, you’ll be sure that the Mediabay database is renewed and not corrupted.

Orherwise, I’m without solution…

Thanks, it seems it did the trick. I wish I could understand how it happened to prevent it to happen again.

I went deep in my memory (I think it was with Cubase 4)… I had a problem similar with Mediabay and presets sometimes here, sometimes not. As I saw the mediabay3.db in the preferences folder, I thought it could be safely deleted as other preferences files. So, I proceeded, rescaned and it solved the problem. The kind of things that you learn the hard way…

Now, don’t ask me why these files can get corrupted : could be anything and it’s something as old as Cubase preferences files history…

Glad you got it sorted.

Yeah, it’s very odd. Cubase is the only software I own that needs to trash its prefs for troubleshooting.
Thanks again!